To preface this, I would like to say that I am completely new to Ubuntu and have essentially zero programming experience/experience working with command line and terminal. I installed Ubuntu because I would like to get into programming. If you could provide me with the simplest instructions possible, I would be grateful.

I have a Lenovo Ideapad Y500 (Intel i7, NVidia GT 750m, 1TB HDD, 16GB SSD cache, 8GB RAM) with Windows 8 on it. Using a Live CD, I installed Ubuntu 12.04 onto a 75 GB partition. During the installation, I kept all default settings except for one thing; I decided to encrypt my home folder, and so checked the corresponding box. The installation completed, and I restarted.

Once I restarted, I saw the options

  • "Ubuntu, with Linux 3.2.0-23-generic"
  • "Ubuntu, with Linux 3.2.0-23-generic (recovery mode)"
  • "Memory test (memtest86+)"
  • "Memory test (memtest86+, serial console 115200)"
  • "Windows Recovery Environment (loader) (on /dev/sdb3)"
  • "Windows 8 (loader) (on /dev/sdb5)"
  • "System Setup"

I chose the first option, and was directed to a screen with the Ubuntu logo and the row of five dots below that change from orange to white. Then, I was brought to a full screen terminal that prompted me to login, which I did. I saw no option to boot into GUI at all, and am lost. I've been searching around and have tried the "startx" command to no avail. Should the command have some sort of context or something?

I've also tried selecting the recovery mode option from the boot manager. I've tried the resume option from the following menu, which eventually just shuts down the computer after displaying a lot of scrolling text that's too fast for me to read.

I've also tried the failsafex mode from the recovery mode menu, which only brings up a terminal box at the bottom of the window that covers the entire bottom part of the screen. Commands won't work in this window.

When I try to access Windows 8, I get a message saying that the EFI file path was not specified or something along those lines. I had to enable Secure Boot in order to access Windows 8 (I had disabled it to be able to boot from the Live CD), which is functioning normally. I am at a complete loss for what to do. Any help will be extremely appreciated.

EDIT: Bonus question! If you could figure out a way for me to boot to Windows 8 without having to enable Secure Boot, it would save me a lot of trouble. I can deal with switching every time, but I'd rather not have to.

  • 1
    The Nvidia GPU you have there is very new. It's only supported by the Nvidia driver 319.17 and up. See nvidia.com/object/linux-display-amd64-319.17-driver.html for the release notes of that version. Try the lastest 319.x driver. The failing graphics is probably the cause for why you only see the textual login. – gertvdijk Jun 27 '13 at 21:21
  • How would I go about installing that driver? – theasianpianist Jun 27 '13 at 22:01

Your hardware appears to be very new. Much newer than the Ubuntu 12.04 release.

Specifically, for your Nvidia GPU (GT 750M) you'll need the 319.17 or newer driver. The 319.x branch is also the latest one, so you don't have much other options than installing the latest in that branch. At the time of writing this is 319.23.

  1. Add the Xorg-edgers PPA and reload the package sources list. In a terminal run:

    sudo add-apt-repository ppa:xorg-edgers/ppa   # confirm the question
    sudo apt-get update
  2. Install all updates.

    sudo apt-get dist-upgrade
  3. Install the newer 319 driver and the settings utility:

    sudo apt-get install nvidia-319 nvidia-settings-319

    Note: if you have hybrid graphics (Optimus: both Intel and Nvidia), also install bumblebee-nvidia to be able to use switchable graphics.

  4. Consider installing the newer 3.8 kernel backported from Raring for your very new hardware:

    sudo apt-get install linux-generic-lts-raring


  • This is just one way of installing the Nvidia driver. I like the Xorg edgers PPA, but others like to install it from upstream.

  • It's most likely that the next Ubuntu release will provide the 319.x driver in the repositories, so with 13.10 and up this won't be needed anymore.

  • I'm currently in the driver installation process, I just want to know what the benefit of installing the newer kernel is. – theasianpianist Jun 27 '13 at 23:06
  • @user170796 Your hardware is very new. To be able to get the most out of it, you should run a newer kernel too. Some features get backported to the 3.2 kernel of Ubuntu, but not all. The 3.8 kernel is from the Hardware Enablement Stack - in order to have more hardware compatible with 12.04 LTS. – gertvdijk Jun 27 '13 at 23:10
  • Ok so I installed the driver and the new kernel, but now when I try to login, after I enter my password and press enter, the screen flashes to black for a second, the quickly flashes the NVidia logo, the goes back to the login page. I am able to get into the system through a guest session, but not my account. – theasianpianist Jun 27 '13 at 23:22
  • @user170796 A working guest session indicates that the driver is installed fine. I'd suggest to ask a new question as to why logging in to your user account does not work (because X crashes presumably). – gertvdijk Jun 27 '13 at 23:23

I'm not sure why you're booting into terminal by default, but as for the Secure Boot issue, once you get into Ubuntu properly, you can install boot-repair from the Software Centre and choose Default Repair. That should add an item called something like Windows 8 UEFI to your boot options, which will boot you into Windows 8. See https://help.ubuntu.com/community/UEFI for more info.


One you have logged into the terminal, try the following command:

sudo apt-get install ubuntu-dekstop

If there is anthing to install anything then continue, and reboot.

Otherwise can you post the output?

  • Executed this command, it displayed a bunch of stuff like extracting files etc. Is there a way for me to capture all the contents of my screen verbatim? After rebooting, it just went back to terminal. I tried the startx command again, didn't work. – theasianpianist Jun 27 '13 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.