32

I have been trying to change my login screen wallpaper to one of my own using ubuntu-tweak. The wallpapers are located in Ubuntu's default wallpaper folder and I have given all users read privileges on them.

Now there isn't even a wallpaper left on the login screen.

  • Have a look at my answer Here, and see if it helps. – Mitch Jun 27 '13 at 20:12
  • I have already tried that and it didn't work. – Joren Jun 27 '13 at 20:30
  • What version of Ubuntu do you have? I use to have a login screen with the wallpaper of the user but now in Ubuntu 13.04 this function is disabled, at least by default.. – Lucio Jun 27 '13 at 22:13
  • @Lucio I'm running Ubuntu 13.04. Would there be an alternative option? – Joren Jun 28 '13 at 13:36
  • In Ubuntu 18.04 this changed again, here is a tutorial, how to change it: vitux.com/how-to-change-login-lock-screen-background-in-ubuntu – rubo77 May 24 at 6:23

15 Answers 15

33

By trying the answer of Senio I had no luck. But with little modification I hit the jackpot :

sudo -i
xhost +SI:localuser:lightdm
su lightdm -s /bin/bash
gsettings set com.canonical.unity-greeter draw-user-backgrounds 'true'
gsettings set com.canonical.unity-greeter background 'path-to-image'
exit

path-to-image is actually the path where the image you want as log in screen wallpaper is stored e.g. : /usr/share/backgrounds/x.jpg

I tested it and it's working

I found this page which offers some tips regarding this problem : Ubuntu13.04 LighDM

  • 3
    And don't forget to give your wallpaper sufficient permissions ;) – Joren Oct 7 '13 at 15:15
  • 1
    I also confirmed that this works in 13.10 too. – Joren Oct 17 '13 at 21:33
  • This doesn't work on my Ubuntu Studio 15.10 , upgraded with ubuntu-desktop – rubo77 Nov 5 '15 at 11:10
  • This doesn't seem to work on 16.04 either: Separate wallpaper for login screen and desktop? (16.04 LTS) – JonasCz Jun 27 '16 at 20:28
  • @JonasCz Works for the lock screen in 16.04 though... – masu Jul 4 '16 at 11:56
8

Cheap and dirty solution: Got to Terminal, then:

sudo nautilus

Then use Nautilus to copy your preferred background to

/usr/share/backgrounds/

Then rename the image that is being used to backup-imagenameold.png Then rename your preferred image to the filename of the original background.

I know it's not clean or lean, but it does the job asap ;)

Cheers, Rüssel

  • Simple, works on Ubuntu 14.04. – Marcel Aug 3 '16 at 22:12
  • This is the only one that worked for me in 16.10 – theYnot Jan 30 '17 at 7:41
7

Hmmm .. I try install dconf-editor to change that background. Open Terminal and type this script ..

sudo apt-get install dconf-editor

Run dconf-editor:

sudo dconf-editor

And show the Window ... Open com > canonical > unity-greeter Then change:

draw-user-backgrounds: 'true'
background: 'path-to-image'
  • This is a good and universal solution -- one probably needs dconf-editor for other stuff anyway. +1 – Priidu Neemre May 28 '16 at 6:25
  • thanks. for me I have to set "draw-user-backgrounds" to false to make the image show, otherwise it's just a color gradient.. good luck. – Bill May 17 '17 at 15:40
7

Its very simple.

  1. Open a terminal
  2. become root and change current folder

    sudo su
    cd /usr/share/backgrounds/
    
  3. Copy the picture file to this location

  4. Change the file name to warty-final-ubuntu.png

That will change the login screen background image.

Source

  • Interestingly this continues to work even for ubuntu 16.04 ... albeit the file must be a png – Scott Stensland Mar 1 '16 at 18:19
5

I believe what you are looking for is:

sudo apt-get install lightdm-gtk-greeter
sudo vim /etc/lightdm/lightdm-gtk-greeter.conf

Change the line:

background=/usr/share/backgrounds/warty-final-ubuntu.png

to whatever you want. Hope this helps

  • Or in one line: sudo su -c 'echo "background=/usr/share/backgrounds/Tranquil_by_Pat_David.jpg">>/etc/lightdm/lightdm-gtk-greeter.conf' – rubo77 Nov 5 '15 at 11:05
  • This does work, but how can I centre the image and scale it to like 0.5 times the original image? – Apurv Feb 7 '17 at 5:09
4

Canonical added the support for it in Ubuntu 16.04. Take a look at this link -> https://help.ubuntu.com/16.04/ubuntu-help/user-changepicture.html

  • 4
    I believe the OP is referring to the background wallpaper, not the little user picture / avatar. – JonasCz Jun 27 '16 at 20:28
  • @JonasCz but the little user picture / avatar will be used as the login screen background! – manniL Dec 23 '16 at 13:38
1

I accidentally have found the solution which works great. It even preserves animation of emerging wallpaper during login screen (which i wanted the most). Step by step what i did:

  1. (lightDM) Change the wallpaper login screen to default. Type in Terminal:

    sudo -i
    xhost +SI:localuser:lightdm
    su lightdm -s /bin/bash
    gsettings set com.canonical.unity-greeter draw-user-backgrounds 'true'
    gsettings set com.canonical.unity-greeter background ''
    exit
    

    This will change logon wallpaper to default. (We need it for animation thing)

  2. Make a startup program named for example 'WallpaperChange', which executes this line:

    gsettings set org.gnome.desktop.background picture-uri \
              file:///usr/share/backgrounds/ur_desktop_wallpaper_here.jpg
    

    During every startup it changes your desktop background on ur_desktop_wallpaper_here.jpg

    Note: Whole path to ur_desktop_wallpaper_here may be changed.

  3. The most important thing. Change your desktop background via GUI in Preferences Options on the wallpaper, which you want to have on logon screen.

  4. Restart your computer.

  5. Uncheck startup program 'WallpaperChange'. You don't need it any more now. During the next change of the wallpaper you will use it again.

I had only tested it on ubuntu 13.04 and found a solution by accident. I cannot provide you a technical answer why it works. It may depend on what you had done with your computer before setting logon wallpaper. I will reinstall ubuntu, try this code again and learn if my solution needs any further editing. (Added 4th line in p.1)

Greets.

  • 1
    I have followed your steps but I am still seeing no wallpaper in my login screen. – Joren Jul 21 '13 at 14:52
1

I am using Ubuntu 14.04 (all Desktop settings are standard and I am using the standard shell) and I think it is even simpler than all solutions stated above.

The only thing I do, is downloading a picture or getting one of my own photos, fitting with the screen size, click the right mouse button on the downloaded picture and select "Set as background".

This process seems to copy the image into the users Picture/Wallpaper folder and, given the right size of the image, will show this picture also at next login.

  • Works nicely for me on 16.04. It is most appropriate for systems that have a single user. The background is obviously user-specific. – Martin Ewing Jul 18 '16 at 3:09
1

I got the simpler way in Ubuntu 14.04 to solve this problem. You just have to change the permissions of image by typing command in terminal as follows.

chmod 644 'path-of-file-to-change-permission'

Replace path-of-file-to-change-permission with the path of your picture.

For example your background images are in /home/Admin/Pictures then type command as follows.

chmod 644 /home/Admin/Pictures/*.jpg

This will work.

0

Simple way, you can change the login background using Nautilus:

  • open Nautilus (in root mode)
  • go to /usr/share/backgrounds
  • cut/move/delete "warty-final-ubuntu.png"
  • then choose the picture you want (.png format)
  • rename it to "warty-final-ubuntu.png"
  • then move it back to /usr/share/backgrounds
  • this was actually the easiest. A lot of the other answers didn't work and were more complex than this – wordsforthewise May 13 '16 at 22:08
0

I was able to change the login screen by accident. It seems to work every time for me. I choose a pic I wanted to use, opened it in Shotwell then Saved it as a PNG format. Then selected that pic as my background. Then I logged out and back in and Bam. The Login screen is the pic I chose.No more ugly orange color. Now, I need to figure out how to remove the grid on the login screen.

0

step 1. Install ubuntu tweak sudo apt-get install ubuntu-tweak

Step 2. Start Ubuntu tweak from commandline: ubuntu-tweak

Step 3. Change the background image Go to Tweaks > Login settings > click to change background image

  • 4
    It would be great if you could elaborate your answer a bit and provide more details to each step. How to install Ubuntu Tweak would be nice as well as a few screenshots maybe. – Byte Commander Mar 19 '16 at 14:43
0
  1. sudo cp your_wallpaper.jpg /usr/share/backgrounds/
  2. sudo chmod 644 /usr/share/backgrounds/your_wallpaper.jpg
  3. sudo nano /usr/share/gnome-background-properties/trusty-wallpapers.xml
  4. Go to the bottom of the file and above the last </wallpapers> tag, copy the text:
<wallpaper>
    <name>Name_of_your_wallpaper</name>
    <filename>/usr/share/backgrounds/your_wallpaper.jpg</filename>
    <options>zoom</options>
    <pcolor>#000000</pcolor>
    <scolor>#000000</scolor>
    <shade_type>solid</shade_type>   
</wallpaper>
</wallpapers> <-- This should be the last line - copy the above text
  1. Save file and exit.
  2. Open System Settings->Appearance->Look tag->Wallpapers from the expanding window. And finally choose your wallpaper which will appear now with the name Name_of_your_wallpaper.
0

In Ubuntu 18.04 you need to change the path to your background image in the default theme /usr/share/gnome-shell/theme/ubuntu.css

  1. First backup the file!!!

    cp /usr/share/gnome-shell/theme/ubuntu.css /var/tmp/
    

    In case you have a typo somewhere, you won't be able to access the login screen itself. If you make any mistake, then you have to fall-back to the terminal to revert the change or make a correction.

  2. Change the background path in the id #lockDialogGroup

    Copy the current image to an unencrypted folder (in case the current image resides inside an encrypted folder) with

    cp "$(gsettings get org.gnome.desktop.background picture-uri|sed "s~'file://\(.*\)'~\1~")" /usr/share/backgrounds/current-background.png
    

    And add this in the #lockDialogGroup section, for example:

    #lockDialogGroup {
       background: #2c001e url(file:///usr/share/backgrounds/current-background.png);
       background-repeat: no-repeat;
       background-size: cover;
       background-position: center;
    }
    
  3. Restart the computer to see the effect.

see https://askubuntu.com/a/1071765/34298

-1

In the past this would work for me. Im am not sure if this will work in a unity environment.

Run this.

sudo cp /usr/share/applications/gnome-appearance-properties.desktop /usr/share/gdm/autostart/LoginWindow


Log out, make your changes.
Log back in
Run this.

sudo unlink /usr/share/gdm/autostart/LoginWindow/gnome-appearance-properties.desktop


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.