I have ubuntu 13.04 and many of my videos do not show thumbnails whereas some do, they are all Mp4 formats including the ones that do show thumbnails.

Is there a way to make all videos show thumbnails?

The ones that do show them were on my old operating system when i had windows 7 so after movinng them from pc to external hardrive to pc (with new os, ubuntu 13.04) the thumbnail remained, whereas new videos do not show the thumbnail.

  • Is it the same files all the time. I had a similar problem, but most of the time it was just taking the thumbnails time to load.
    – Dan
    Jun 27 '13 at 18:29
  • yer its the same files, only 4 specific videos show the thumbnail every time and the rest don't show them ever, no matter how long the folder is open for.
    – UbuntuFan
    Jun 27 '13 at 18:36

First install:

sudo apt-get install ffmpeg ffmpegthumbnailer gstreamer0.10-ffmpeg


sudo gedit /usr/share/thumbnailers/totem.thumbnailer

replace contents with following:

[Thumbnailer Entry]
Exec=ffmpegthumbnailer -s %s -i %i -o %o -c png -f -t 10
  • This worked for me perfectly, thank you very much nightcrawler! Dec 27 '14 at 5:17
  1. Install ffmpegthumbnailer
  2. Delete the fail folder inside .thumbnails in home directory.
  3. Change the permissions of folder ".cache/thumbnails" in home directory by following command:

    sudo chmod 777 -R .cache/thumbnails
  4. Delete the files inside folder .cache/thumbnails/fail

  5. Kill nautilus and restart nautilus
  6. Visit the video folder :)
  • This did not generate thumbnails for my mp4 video files.
    – Cerin
    Oct 23 '17 at 0:25
  • Loaded my thumbnails without changing folder permissions. Dec 7 '17 at 20:44

Try this. Install libxine1-ffmpeg, it might be needed for some thumbnails. To install, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install libxine1-ffmpeg
  • Didn't work, any other ideas? I have also tried Files > Preferences and changing the show thumbnails to "Always" but still dont work.
    – UbuntuFan
    Jul 12 '13 at 22:43

From: Gnome 3 not displaying thumbnails?

Had the same problem with Ubuntu 13.10 - Gnome3. Solved it deleting whole folder thumbnails in /.cache and remaking it.

1) Disable preview in nautilus by opening home folder, Edit-> Preferences-> Preview.

2) sudo rm ~/.cache/thumbnails

3) Empty trash can

4) sudo mkdir ~/.cache/thumbnails

5) Reboot

6) Enable preview, again home folder, Edit-> Preferences-> Preview.


Worked for me.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.