3

I have PC with XUbuntu 12.04 and Samsung 27A950, so I want to use my PC like dlna server. But I can run file of any format on my TV, get error: "File format doesn't support". I try to open *.avi, *.mkv and *.jpg files the same result. In error log I can see:

[2013/06/27 12:34:03] upnphttp.c:1907: error: Error opening /home/family/media/file1.mkv
[2013/06/27 12:34:06] upnphttp.c:1907: error: Error opening /home/family/media/file2.avi

So, I have no idea why it doesn't work. Any suggestions?

miniDLNA version:

Version 1.24.1-stedy

Config file is default, only few directories added. With version of the default Ubuntu repository was the same. Some time ago I tried mediatomb, had the same error.

3
  • I decide install ps3mediaserver. It works. – Vasya Jun 27 '13 at 12:45
  • Out of the box? Including .avi etc. on your TV? Would you mind to post an answer with steps you've taken, and how well it works with different formats? – Izzy Aug 6 '13 at 15:26
  • I had the same problem. Every time I tried to play my media files on my samsung tv i got a message that the file format is not supported. Changing the port to 9500 worked for me. :) – user277793 May 4 '14 at 12:00
1

Here are the settings of our /etc/minidlna.conf to stream audio, video, or pictures without issue to our Samsung UE40ES6100 smart TV:

Port

Make sure you stream on the port your TV listens to. You may also have to make sure that this port is accessible for your TV from your router. In case the port is wrong your TV may not see miniDLNA at all.

port=9500

Media directories

Put here the directories to add to miniDLNA's media library. These directories may need consideral time for scanning on the first run. Unfortunately there is no feedback from miniDLNA when it is finished with scanning. Make sure the group minidlna has read acess to these directories. Replace the full path and directory name with your's.

media_dir=V,/<path>/<Videos>
media_dir=A,/<path>/<Music>
media_dir=P,/<path>/<Pictures>

Data base and log directory

This is where miniDLNA stores it's database and log files. It's crucial to give the group minidlna write permission to the path you give here.

db_dir=/home/<user>/.config/minidlna # or any other directory
log_dir=/home/<user>/.config/minidlna # or any other directory

Model number

This may not be needed, but our TV did not recognize miniDLNA unless we gave it the model number AllShare here.

serial=
model_number=AllShare1.0

Other settings

These settings were set per default but I will post them here just in case they are not.

network_interface=eth0 # change appropriately, e.g. wlan0 if you stream from wireless
friendly_name=miniDLNA # how miniDLNA is named on the TV
enable_tivo=no
strict_dlna=no
notify_interval=900
1
  • 1
    For me, it worked fine with pictures − but completely failed with video. They were listed fine, but trying to play them always resulted in an error for "unsupported format". Didn't you have that issue? // What really killed the cat was miniDLNA completely filling the disk with an almost 50 GB log while opening "too many http connections" and complaining about that failure :( – Izzy Aug 6 '13 at 15:30
0

While .jpg worked fine for me (with an UE55ES TV), most movie/video files do not via DLNA (but only if served locally, e.g. using an USB stick). This seems to be a limitation of the TV device, as you find it reported frequently.

So miniDLNA is not really an option if you want to serve most videos (moreover, it sometimes manages to almost bring the entire system down by completely filling up the partition /var/log is located on: opening too many http connections and then complaining about it in its logs, it reached almost 50 GB log file size on my machine, so I had to stop it).


You might want to take a look at a different DLNA server, like e.g. Serviio, which uses FFMpeg to transcode media files to a format understood by the device. I just tried to set this up on my machine yesterday: unfortunately, Canonical decided to drop FFMpeg from the repositories (you can still do an apt-get install ffmpeg successfully, but that delivers a different software including some "ffmpeg compatibility" stuff, which seems incompatible with Serviio. On their site, however, they explain how to build FFMPeg from the sources − if that's an option for you. Looks like too much pain for the normal user to me, though.

Edit: Serviio seems to work fine with my UE55ES out-of-the-box, even with the Generic profile. I followed this German HowTo to install it. As for FFMPeg, there are static binaries available for download. Simpy downloading the tarball, and extracting the two files to /usr/local/bin did it for me.

Other possible alternatives to take a look at (none of them I tested yet):

  • Rygel (can at least be installed via PPA, transcoding supported). According to a German Howto, it also seems to be available in the regular repos, so you should be able to simply apt-get install rygel (plus optionally rygel-preferences for a management frontend and rygel-mediathek as well as rygel-tracker for some more plugins). But as the support for Samsung TVs seems to have been added only recently, the version in Precise's repository does not work for you − the "official PPA" might to be favored.
  • Mediatomb: As Samsung TVs (at least those of 2012) are not complying with RFC2396, this requires a manual installation as well to be used with them. May sound a big deal at first, but as described at gnulnx.net it seems to be quite straight-forward. (A simpler method is described here, if you want to test it: it just involves editing a text file)
  • PS3MediaServer (aka PMS) you already mentioned to be working fine, so I probably will have to take a closer look at it, too ;)

Other solutions like e.g. XBMC seem to heavy-weighted to me for the purpose. An interesting overview for other alternatives can be found e.g. at MakeUseOf.

To check whether your uPnP server works in general, you can e.g. use eezUPnP on your Ubuntu workstation.

0

Know this an old post, but someone might search it and help them with MiniDLNA

I run Ubuntu 1204lts. Had minidlna working sweet.

Then installed owncloud and it broke my minidlna install - TV said file not supported - XBMC similar errors. Would just list media, not play anything.

Once i removed owncloud, I also removed, libav-tools, libavfilter2, libavdevice53 - miniDLNA working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.