I can get the pendrive to boot in Legacy (aka BIOS) mode, but I can't get it to boot in UEFI mode.

When I attempt to boot in UEFI/Secure mode, it complains before Grub even starts.

If I boot UEFI/Insecure mode Grub starts, but the machine freezes immediately after attempting to boot the OS.

By editing Grub's boot entry to include echos in stategic places, I have been able to establish that Grub does indeed manage to load both the kernel and the ramdisk into memory, and then the machine freezes.

The freeze happens regardless of whether I use nomodeset or not. I even tried noapic and nolapic and acpi=off (blind shots, I know), to no avail.

I found quite a few similar questions around here, but no answers that would help me further.

I was able to install Ubuntu to the disk from the pendrive in Legacy mode, but for some reason I can't boot the disk installation: grub starts, but it doesn't even get to the menu and drops me to the rescue prompt.


In the case where you get into the initramfs, adding "quiet splash debug=yes" might at least get some useful debugging output on screen. Also "set debug=all" in GRUB should establish whether it gets to the point of actually booting the files it's loaded into memory.

| improve this answer | |
  • I did just that: "set debug=all" all by itself and "debug=all" in the linux command line (I deleted quiet and splash). I also added an "echo done" after loading the ramdisk, for good measure. I don't see anything unusual in the output. Some messages from kern/disk.c and disk/efi.efidisk.c about reading the files, and others from script/script.c, mainly mallocs and tokenizing. The last three lines are "token 0 text []" followed by two mallocs. And then it stops, with no output from the kernel. – Federico Heinz Jun 26 '13 at 18:23
  • Another data point? The above happens when secure boot is enabled. When I disable Secure Boot, it hangs trying to read kernel, just after printing "Trying to allocate in 0x0-0xffffffffffffffff aligned 0x1 size 0x1345000". – Federico Heinz Jun 26 '13 at 18:33
  • On a hunch, I decided to try and burn the ISO on a DVD+R, see if the problem was with the USB drive, but it turns out to fail in exactly the same way. – Federico Heinz Jun 26 '13 at 20:26

I have exactly the same problem with MSI GE40 2OC notebook. The BIOS/EFI is American Megatrends Aptio with the last update from 2013-07-12 (version 10F). An slight difference is in the size in the last line "Trying to allocate in 0x0-0xffffffffffffffff aligned 0x1 size 0x1345000", which is in my case 0x1344000.

My current (quite hacky) solution is to switch in the BIOS the legacy mode (for linux) and UEFI mode (for preinstalled win8) before changing the OS in which I need to work. Since the changes GRUB made in MBR during the legacy mode installation does not influence the UEFI booting, this works. Nevertheless, it is quite a pain, to go to bios for OS switch.

The last line seems to be from grub2, so maybe I will report an bug later.

| improve this answer | |

I had a similar problem. My BIOS rebooted immediately when forcing UEFI boot. It was because the pen drive did not have a UEFI bootloader. I used a GPT formatting utility called rufus to flash the image to the drive, and it worked like a charm! It booted in EFI mode (black screen instead of purple) on the first try.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.