15

I have attached screen shots of htop and it's bizarre results. Can anyone explain what is happening here? It shows this new copy.com app taking up like 500% of my memory if you count it up.

enter image description here

enter image description here

19

What you're seeing is perfectly normal. If you'd like to have an easier view on the eyes (that still shows correct information) you can perform the following steps in HTOP:

  1. Press F2 to enter the Setup menu.
  2. With "Setup" selected on the left, press the down arrow until you have "Display Options" hilighted.
  3. Press the right arrow (->) to move the cursor to the next column and press the "space" key to select "Tree View".
  4. Press the down arrow and select "Hide kernel threads" by pressing the "space" key.
  5. Press the down arrow again and select "Hide userland threads" with the "space" key.
  6. Press F10 to save your changes.

What you are seeing by default is a representation of all of the kernel and userland threads being reported. By following the above steps, you'll not show these threads and have a cleaner view of the running processes on your system.

If you'd like, here is what I have in my ~/.config/htop/htoprc file:

# Beware! This file is rewritten by htop when settings are changed in the interface.
# The parser is also very primitive, and not human-friendly.
fields=0 48 17 18 38 39 40 2 46 47 49 1 
sort_key=46
sort_direction=1
hide_threads=0
hide_kernel_threads=1
hide_userland_threads=1
shadow_other_users=1
show_thread_names=1
highlight_base_name=1
highlight_megabytes=1
highlight_threads=1
tree_view=1
header_margin=1
detailed_cpu_time=1
cpu_count_from_zero=0
update_process_names=1
color_scheme=0
delay=15
left_meters=LeftCPUs Memory Swap 
left_meter_modes=1 1 1 
right_meters=RightCPUs Tasks LoadAverage Uptime 
right_meter_modes=1 2 2 2 
  • I found that I had to edit my ~/.config/htop/htoprc file in order for the settings to persist across launches of htop. In other words, simply following the numbered steps didn't work, I had to change hide_userland_threads=0 to hide_userland_threads=1 manually. – Søren Mortensen Feb 12 '18 at 19:07
  • @SørenMortensen - That could very well be due to the terminal emulator you're using (F10 may be getting hijacked to display your terminal emulator's menu). That's one of the reasons why I posted my config, in case directly editing the config file was necessary. – darthlukan Feb 19 '18 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.