I'm going to give you real breakdown of events to clarify what has happened.

I’ve just rebuilt a rig I haven’t used for almost a year, it's running Windows 7 and Ubuntu 10.04. I couldn’t remember the login for Windows so was recovering files in Ubuntu and preparing to wipe Windows 7, I recovered some files and deleted some files.

I got a popup saying Ubuntu is ancient and needs upgrading as its not supported so I clicked upgrade via update manager, it did its thing and started to download the files. This was unsuccessful at the install stage, it was stuck for hours so it got shut down at 3am. The next day, I booted up and it says on start screen Ubuntu 11.10 with the little dots but doesn’t boot, I tried previous Linux versions in Grub with same result.

To make matters worse I remember my Windows login and boot it up to be confronted with a temporary profile as some of the files removed/deleted are needed for the profile.

I'm using a live usb of 12.04 lts and have used ecryptfs-recover-private and have access to the encrypted home folder from 10.04 but I cannot find these deleted files, I've checked in ~/.local/share/trash and the three folders are empty. so I may have emptied the trash bin, I cannot remember,but I know there are still techniques to recover the files.

So after all this, I would like to recover my install of Ubuntu 10.04 or recover the lost data, copy and save all the important files from /home and do a fresh install of 12.04.

Sorry that was so long :D


Problem solved.

I used a live USB of 12.04 and ran sudo ecryptfs-recover-private after mounting the target drive with the previous install. I followed the prompts and entered my login and it was decrypted to a temp folder. Using gksudo nautilus I copied the entire home directory to another HDD. I made a fresh install of 12.04 and then copied the same folder to desktop, I could not unmount the drive after and noticed that the trash was full, it contained the same files I had deleted from windows, I copied those files back to the windows HDD rebooted and everything is back to normal.

BACKUP before you do anything, i was very lucky on this occasion.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.