I use an Acer Aspire One with Xubuntu (12.04). Last night I installed a few updates, only the security ones because it was late. It finished OK with a message about needing to restart for the changes to be effective.

Today I have 3 issues:

The first is that network manager is misbehaving. The network icon is 2 little arrows.
Hovering over it gives the help text: Networking disabled. Clicking on it says: NetworkManager is not running... and a right click shows a limited menu (3 lines) with only one option not greyed out: Edit connections.

If I check with service network-manager start, it says start: Job is already running: network-manager. I tried to stop then, restart. The networking icon hasn't changed, but the messages are different: Hovering over it is still the same (networking disabled) but with left click it says No network devices are available (in grey) and I can click on VPN connections. While on right click it gives the same menu as previously, but now the greyed out Enable networking has a tick in front of it.

I searched online, and the closest I found was this. Although I am not running Mate.

The second problem is that when I click on the Shutdown icon I get an error window:

Unable to perform shutdown
Shutdown command failed  

And I can only click on Quit or hit enter, which brings me to a login screen. Attempts to shutdown from there fail too. I can however shutdown by typing sudo shutdown -P 0 in a Terminal.

Finally, the USB ports do not work, in as much as I cannot mount anything inserted. The memory slot does not work either. As I only noticed this last issue after posting my original question I will go and search online some more to see if I can revert to the pre-upgrade situation without going online nor using a USB port.

Many thanks



OK, I am a fool.
The solution was to run Update Manager again. It complained about some half-unpacked packages then about the lack of internet connection so that the update could not be completed. This seems to have cleared something, maybe reverted the unfinished update.
I then attempted a restart, which failed (same as when I could not shutdown) but upon loging in from the login screen I could then initiate a succesfull restart and my little laptop is back up and running.

I wrote that I was a fool because although I thought I could shutdown after running Update Manager and it would finish its business when I next turned on, I should have opted for the proposed restart then, and none of this would have happened.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.