When I installed Ubuntu 12.04, I didn't know how to properly set the mounting points for the partitioned logical drives. So, I just set it randomly. Now when I open the Home folder I cannot see any of the logical drives on the left pane. I tried to change their mounting point but couldn't.

The contents of my fstab file /etc folder is:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=691fa0bd-350f-4378-b5c7-82d277dd83c2 /               ext4    errors=remount-ro 0       1
# /srv was on /dev/sda8 during installation
UUID=753d012e-ac3c-42fd-b388-d83115e88d26 /srv            ext4    defaults        0       2
# /tmp was on /dev/sda5 during installation
UUID=34d8c35a-7900-4acd-988d-880792849673 /tmp            ext4    defaults        0       2
# /usr was on /dev/sda6 during installation
UUID=4f7f4287-5feb-4b2b-86bb-93fe74905149 /usr            ext4    defaults        0       2
# /var was on /dev/sda7 during installation
UUID=e2933e36-7906-48ac-b2ac-93500537cd4a /var            ext4    defaults        0       2

My Partitions are mounted at the following locations: /dev/sda5 is mounted at /tmp; /dev/sda6 is mounted at /usr; /dev/sda7 is mounted at /var; /dev/sda8 is mounted at /srv.

If I attempt to change the contents of fstab file, it says that only root can change the contents.

How do I change the mounting points of the partitions such that they show up in the Home folder?

  • 1
    You don't have to mess with mount points, instead, just create symbolic links inside the home folder that point to those partitions. For example, to create a symlink (named var) to /var, run ln -s /var var. Jun 23, 2013 at 18:32

2 Answers 2



A gui solution would be to use Disks. From there you will be able to edit the mount points of the secondary drives using the Edit Mount Points option - just unmount to edit themDisks screenshot

  • If you meant the Disk Utility, I have already tried it. I was unable to unmount the partition using it or by using any other means. Jun 30, 2013 at 7:09
  • @Dineshkumar Just want to make sure that you got them unmounted and got the mount points changed (don't know your level of English and want to make sure that 'was unable...' means that you are now able to unmount)?
    – chesedo
    Jun 30, 2013 at 7:53
  • No, I am not. It should have been 'I am unable...' Jun 30, 2013 at 8:08
  • @Dineshkumar Try unmounting using sudo umount /dev/sda5 and the same for sda6, sda7 and sda8 if it works. Or you can also try Ilya's answer to open /etc/fstab with root rights and them change the mount points and saving (saving should auto unmount and remount them).
    – chesedo
    Jun 30, 2013 at 8:13

You change it in the mounting points in fstab, as you correctly tried. To do it you need to open /etc/fstab with root rights. For that type in a terminal:

sudo gedit /etc/fstab

There is a lot of information about that on the internet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .