1

I'm sorry if this question has been asked already, but I think mine is a very rare case(if it is).

So the story goes like this: I was able to "remove/uninstall" GNOME UI (I just want to call it UI, and I want the default/stock Unity "UI"). Unfortunately, I restarted my system, hoping that Unity "UI" would be loaded, but there's no Unity UI preinstalled!

I'm using GRUB bootloader, Ubuntu is installed with Windows 7 Pro 32 Bit(But on other partition, of course). Also, I have my preinstalled apps, and I'm just using Ubuntu for about this day only(Yeah, you can call me a noob or whatever).

In short, I can boot Ubuntu properly, but I can't log in. I tried to do a recovery, but I aborted it (foolish, huh?).

Do I have to do a reinstallation of the OS? Or I should type commands in GRUB bootloader (if possible)?

I'm sorry for my long story, and wrong grammars(if there are :D). Do you know any solutions? Quick responses are VERY appreciated.

1

If I understand your problem, you tried to remove Gnome Desktop and now you have no login screen so you cannot log in.

Not sure what command you might have used but alot of Gnome programs are a dependant of the Unity desktop.

You should still be able to log into Ubuntu using the terminal as you say you can still boot.

After booting press Ctrl+Alt+F1 this should get you to tty 1. If so enter your username and the press enter. Enter your password at the prompt note that you will not see any response to your keypress but they will still register(this is a security feature).

After you enter your password press enter and you should be greeted with a line that has your username and the computer name followed by ~$ if so you have successfully log in to Ubuntu but with not Desktop environment. We can now try to reinstall a DE to use.

Type this into the terminal sudo apt-get install ubuntu-desktop This should install the Unity desktop as well as any dependencies that you may have deleted when you tried to remove Gnome.

If successful you should be able to restart and use your Unity Desktop. To restart type sudo reboot into the terminal and your computer will reboot just like you had done so from the UI.

If you still get no login screen restart and log into the terminal and type sudo apt-get install lightdm unity-greeter
I think these are installed when you install ubuntu-deskop but I was unable to verify that. You can install them at the same time you install the desktop if you want, they will not reinstall if you already have the latest version and will give you a warning as such but will do no damage.

Note that this will only work if you still can connect to the internet, if you have borked your system so that you can no longer connect you may be able to install from the live media that you installed Ubuntu with but it may or may not work. It may still be possible to get it installed by manually setting up the connection in the terminal but that is beyond my knowledge.

Note #2 If for some reason you cannot log into Ubuntu when you press Crtl+Alt+F1 then boot to recovery mode (press Left Shift repeatedly during boot then select recovery mode with networking) and then you should be able to follow the instructions to install ubuntu-desktop.

  • Thank you for your response. :) I couldn't login to the command Ctrl+Alt+F1. I just did a fresh install of the Ubuntu, and everything worked well, exept for my wireless network. I can't enable it. :( Any solution for thet? I'm really sorry for my problems. I'm just a newbie.. :) – David Jun 24 '13 at 12:58
  • @David I don't know about wireless but there are many questions here that deal with the problem....here are two. If you are getting a warning that "Wireless is disabled by hardware switch" see here If you have a Broadcom Wifi adapeter see here. If these don't help just search the site and see what looks similar to your issue with the wireless...there are too many for me to try and link to. If all else fails ask another question and you should be able to get some help. – TrailRider Jun 24 '13 at 22:10
  • Thank you for your response. I am not getting any warning or issues with my hardware, and it is detected in my system. But when I'm trying to enable my hardware, it doesn't respond anymore. I'm just wondering why it is not working now but in my first installation of Ubuntu, everything works well. I'll try to test the links that you gave me. I appreciated it. Thanks again! – David Jun 25 '13 at 13:06
  • I think I just knew my problem. I booted up Windows 7 and checked my drivers if they are properly installed. I noticed that almost everything is restored to default (I mean every drivers are provided by Microsoft)! Later I'll try to boot Ubuntu, and check if it will work perfectly. Again, I'm all giving you thanks for your help. :) – David Jun 25 '13 at 13:22
  • @David The drivers in windows should not affect your Ubuntu install but if you started a system restore in Windows(I assumed by your question that you tried to use Ubuntu's recovery mode) it would have wiped your Ubuntu install. Even if you started it and stopped it it would likely have at least messed up the partition table and that would have borked your Ubuntu install. If you did a complete reinstall of Ubuntu that should have taken care of you Ubuntu partition and you should have a working Ubuntu once again. You can safely update you Windows drivers w/o affecting Ubuntu. – TrailRider Jun 25 '13 at 22:01
0

You probably don't need to install the whole system again. I would start by reinstalling Unity by following the instructions from this answer.

When you are in the login screen, try clicking on the small Ubuntu icon next to the text box and select other than the default session (which is likely to be Ubuntu in your system). If the list is empty or the options don't work, you would need to boot to the recovery mode from GRUB to reinstall Unity.

If you need to use the recovery mode, select the "netroot" option and type the commands from the linked answer but without the sudo word (since you'd have root permission already).

  • The answer you linked to had the OP with only Gnome and he wanted to reinstall Unity. So he had a way to log in, the OP of this question has no desktop to start from so he will need to log in to the terminal, then the answer should work.... – TrailRider Jun 23 '13 at 15:43
  • I tried to cover that possibility by Grub's recovery mode. – papukaija Jun 23 '13 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.