12

There is this proposed solution to disable the blinking cursor in Gnome terminal. However, it no longer seems to work for Gnome 3.8. The option /apps/gnome-terminal/profiles/Default in Gconf does not exist.

So, what is a working solution for Gnome 3.8?

15

Try (in a terminal):

gsettings set org.gnome.desktop.interface cursor-blink false

As your can see the key has been moved to org.gnome.desktop.interface (via GSettings), so you can access it via dconf-editor if you prefer so.

  • 1
    To disable only in gnome-terminal in Gnome 3.8 and above, try: dconf write /org/gnome/terminal/legacy/profiles:/:<profile-uid>/cursor-blink-mode "'off'". The profile UID can be obtained from the profile preferences. Thanks to ArchWiki docs for the help. – g13n Mar 28 '15 at 17:23
4

None of the above worked for me on Debian Jessie. I worked out the following solution from recent gnome docs

## Find profile, see also Edit -> Profile Preferences -> Profile ID
gsettings get org.gnome.Terminal.ProfilesList list

## Substitute the relevant profile for UUID below - but include all / and :
gsettings set org.gnome.Terminal.Legacy.Profile:/org/gnome/terminal/legacy/profiles:/:UUID/ cursor-blink-mode off

## Disable globally (except gnome-terminal has its own config)
gsettings set org.gnome.desktop.interface cursor-blink false

To automate this for all profiles, enter in bash

for uuid in $(gsettings get org.gnome.Terminal.ProfilesList list | tr -d "[',]"); do
    gsettings set org.gnome.Terminal.Legacy.Profile:/org/gnome/terminal/legacy/profiles:/:${uuid}/ cursor-blink-mode off
done

This retrieves the UUIDs from the profile list as above with gsettings, and removes unneeded characters [',]. The resulting list is used in setting the cursor-blink-mode to off.

  • Well, that is certainly intuitive, and obviously much better than the old "toggle the checkbox" interface... WTF are they thinking? – Nemo Jul 6 '17 at 21:19
2

Try this. To disables cursor blinking desktop-wide:Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

gconftool-2 --set /desktop/gnome/interface/cursor_blink --type bool false

To disable blinking just for Gnome Terminal’s Default profile:

gconftool-2 --set /apps/gnome-terminal/profiles/Default/cursor_blink_mode --type string off

Source:M.Friedrich

  • Hi Mitch. This does not work. The cursor in the Terminal is still blinking. Furthermore, it is exactly the same approach I have referred to and also had described that it is not working with Gnome 3.8. – Dan Sherban Jun 23 '13 at 11:29
  • I have changed the commands in my answer. Try it, and let me know. – Mitch Jun 23 '13 at 11:40
  • Unfortunately still not working. Does it work for you? – Dan Sherban Jun 23 '13 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.