This happens a lot when I spend my day watching online videos (especially long ones).

When I exit Full scren from flash video, the whole screen becomes white and I can't do anything to fix it.

I try to go CTRL+ALT+F12 and than CTRL+ALT+F7 but it stays white when I return to Graphical mode.

I resolve it by killing ligtdm and starting it again from tty.

I have Ubuntu 13.04, latest chrome and latest updates. I have Intel i3 Processor with integrated GPU Intel® Ironlake Mobile x86/MMX/SSE2.

  • I'm not sure where flash logs its messages, but try opening Chrome from the terminal with chrome 2> ~/messages1 1> ~/messages2, reproduce the bug and provide the contents of messages1 and messages2. Also provide tail /var/log/syslog and tail /var/log/Xorg.0.log. – edwin Jul 13 '13 at 3:15
  • Do you have any NVIDIA GPU in addition to onboard graphics? There was a bug in NVIDIA drivers that cause this problem. – Johankor Jul 15 '13 at 18:08
  • Exact same problem here, on Ubuntu 12.04 – Jonathan H Aug 20 '13 at 0:50
  • Anecdotal evidence seems to suggest that (on my computer) Firefox is unaffected by this issue while Chrome isn't. – Umang Sep 17 '13 at 2:30
  • Exact same problem on Ubuntu 12.04 64bit, Intel HD4000 graphics. The behavior is not deterministic. I can't reproduce it even when I'm watching the exact same video. Every time I restart the lightdm service from the tty, after a white screen incident, teamviewer also opens (without having used it before), I don't know if this is relevant but I also don't know why this happens. – naskoos Sep 18 '13 at 17:18

This indicates an issue with your web browser Flash plug-in. You must have the latest Flash Player installed to use full-screen mode and for hardware-scaled full-screen mode.

My best guess is that the things you are trying to view require the latest versions of java, and flash player. Also you can try HTML5, and see if the problem exists, or it disappears. You could also ty other browsers, to see if the problem still exists.

Try using Firefox, but before playing a video, Type about:config in Firefox address bar, then type plugin.expose_full_path in the filter, then double-click it to make it true. Then type about:plugins in the address bar, find Shockwave Flash, make sure that that path is correct.

Path: /usr/lib/flashplugin-installer/libflashplayer.so
Version: Shockwave Flash 11.x rxx 
| improve this answer | |

I have the same problem. What I do to fix it is: I switch to the command mode (Ctrl+Alt+F1) and type unity restart, then press Ctrl+Alt+F7 to return back to the ordinary screen.

| improve this answer | |

This problem happens with Intel video adapters and Chrome built-in pepperflash. It can be fixed by disabling pepperflash in chrome://plugins

flashplugin-installer package must be installed to use external flash 11.2.

| improve this answer | |

Fixed for me when I turn off hardware acceleration in Flash:

  1. Right click on your flash video
  2. Settings
  3. Uncheck "enable hardware accelaration"
| improve this answer | |

I had exactly the same problem but I couldn't get along with restarting the whole X-window, loosing all my work, so I tried different things like killing some processes (like plugin-container) from the top list, but without much success when I noticed that some pop-up windows work - Firefox telling me downloads complete, print-screen key showing some parts of the screenshot dialog. Further I found out that this weird behaviour also let's me start my guake terminal with it's F12 key and that it even shows the task bar then!

Then it was somewhat easy to just select the Firefox and with the Alt+F4 shortcut try to quit it, which made the screen to the expected state again:) (showing minimized frame of the video with the information that Flash failed). I'll edit here when I'll have more precise instructions, but this just worked for me now to fix that problem.

| improve this answer | |

Here is something who are looking to restore your current session without loosing your unsaved work.

Open tty1 by using the Ctrl+Alt+F1 combination.

kaushik:~$ pstree -p|grep lightdm
        |               |-lightdm(2062)-+-gnome-session(2253)-+-compiz(27013)-+-{compiz}(27014)
        |               |               `-{lightdm}(2209)
        |               |-{lightdm}(1298)
        |               `-{lightdm}(1302)

You'll see a gnome-session running as child to lightdm. Note down the gnome-session's PID.

My common sense says that killing gnome-session should end my session abruptly but it didn't actually do so. On previous occasions I killed lightdm and messed up my session. So I just gave a try killing gnome-session and it worked (that was the best I could think of). I tried killing again to confirm. What happens is tty7 goes blank for fraction of second and then everything restores peacefully. However, please do it at your own risk, don't hold me responsible; I'm not an expert :)

pkill -KILL -P  ITS_PID

(Replace ITS_PID with what you just noted down. 2253 in my case)

Once you're done, come back to tty7. Use Ctrl+Alt+F7 combination.

I run Ubuntu 12.04 64bit and Compiz by the way. Would be nice to have some expert opinion on this, I'm lazy to do some research on this.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.