98

I have tried searching previous questions for answers to my question but all of the answers that have been suggested previously haven't worked for me.

I am trying to connect to a linode (running ubuntu 12.04 LTS) from my local machine (also running ubnutu 12.04 LTS)

I have create a private and public key on my local machine and copied my public key to my linode's authorized_keys file. However whenever I try to ssh to my linode I get the error message "Permission denied (publickey).

Its not a problem with how ssh is set up on my linode because I can ssh to it from my Windows machine using key authentication.

In my .ssh directory on my local ubuntu machine I have my id_rsa and id_rsa.pub files. Do I need to create an authorized_keys file on my local machine?

EDIT: This is what I get when I run ssh -vvv -i id_rsa [youruser]@[yourLinode]

debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
Permission denied (publickey).
  • 3
    1) What do the logs on the SSH server say about the time you have this error on the client? (/var/log/auth.log) 2) How did you transfer the public key to the server? Always use ssh-copy-id to be sure about permissions. Your home directory, the .ssh directory and the authorized_keys file have strict permission requirements. (see manpage of sshd (8) on ~/.ssh/authorized_keys). 3) Did you generate a new keypair on Ubuntu? In case you reused the key from Windows - you'll have to convert it to OpenSSH format first. – gertvdijk Jun 23 '13 at 1:13
  • The command should have been ssh -vvv -i .ssh/id_rsa .... (note the path to id_rsa!) - please replace - the old log only shows that "we" had no pubKey to send. – guntbert Jun 23 '13 at 11:22
  • @guntbert I missed out the .ssh because I was already in the .ssh directory. I also tried it with .ssh/id_rsa but I got the same result – Pattle Jun 23 '13 at 11:30
  • I see, so I misread - Please answer the questions from @gertvdijk. – guntbert Jun 23 '13 at 11:40
  • Can anyone comment on stackoverflow.com/questions/51254328/unable-to-ssh-to-bitbucket I have a similar problem. – Mrinmay Kalita Jul 9 '18 at 22:38

18 Answers 18

83

PubKeyAuthentication

Set up your client

  1. Generate your key
    • ssh-keygen
  2. Configure ssh to use the key
    • vim ~/.ssh/config
  3. Copy your key to your server
    • ssh-copy-id -i /path/to/key.pub SERVERNAME

Your config file from step 2 should have something similar to the following:

Host SERVERNAME
Hostname ip-or-domain-of-server
User USERNAME
PubKeyAuthentication yes
IdentityFile ./path/to/key

You can add IdentitiesOnly yes to ensure ssh uses the IdentityFile and no other keyfiles during authentication, which can cause issues and is not a good practice.

Troubleshooting

  1. use "-vvv" option
  2. Make sure the server has your PUBLIC key (.pub).
  3. Make sure your IdentiyFile points to your PRIVATE key.
  4. Make sure your .ssh directory has 700 and your files are 700 permissions (rwx------).
  5. tail -f /var/log/auth.log (on the server) and monitor errors when you attempt to login
  6. If you have many key files, try IdentitiesOnly yes to limit the authentication to use the single, specified key.
  • 1
    FYI, I created a small script at github.com/centic9/generate-and-send-ssh-key which runs the necessary steps in one go and additionally ensures all the file/directory permissions which always caused me headaches... – centic Oct 7 '15 at 11:30
  • 1
    Just to elaborate step 2: the IdentityFile line in ~/.ssh/config must point to the PRIVATE key. – Danny Schoemann Aug 30 '17 at 14:19
  • Indeed. – earthmeLon Jun 12 '18 at 20:40
  • 1
    I wonder why you'd want to set files to have execute permission in step 4? – Todd Walton Nov 7 '18 at 13:43
54

Sometimes the issue comes from permissions and ownership. For instance, if you want to log in as root, /root, .ssh and authorized_keys must belong to root. Otherwise, sshd won't be able to read them and therefore won't be able to tell if the user is authorized to log in.

In your home directory:

chown -R your_user:your_user .ssh

As for rights, go with 700 for .ssh and 600 for authorized_keys

chmod 700 .ssh
chmod 600 .ssh/authorized_keys
  • 1
    This answer helped me. I had taken the advice from this post and moved my authorized_keys file outside of my encrypted home directory. In doing so, I had inadvertently changed ownership to root:root. – Jordan Grant Aug 12 '16 at 22:27
  • Wish I could upvote twice, once for the folder and once for the file. Very important that permissions are exact. – Mr Griever May 15 at 18:21
14

You don't need authorized_keys on your client.

You must tell the ssh-client to actually use the key you generated. There are several ways to do that. Just for testing type ssh -vvv -i .ssh/id_rsa [youruser]@[yourLinode]. You will have to provide your passphrase every time you want to connect to the server.

If that worked you can add the key to the ssh-agent with ssh-add .ssh/id_rsa (you will have to provide the passphrase only once for this and it should work as long as you don't logout/reboot)

  • Thanks for your help, I have edited my answer to show what happens when I type what you suggested. – Pattle Jun 22 '13 at 23:22
  • 2
    to transfer a key, on the client, use ssh-copy-id – Panther Jun 23 '13 at 0:30
  • @bodhi.zazen Thanks, but I have already transferred the key, that isn't the problems – Pattle Jun 23 '13 at 0:33
  • 4
    "You must tell the ssh-client to actually use the key you generated." No, by default it will look for the key in the default path, e.g. ~/.ssh/id_rsa. Also, the use of a key agent is completely optional and unrelated to the issue as far as I can see. – gertvdijk Jun 23 '13 at 1:09
  • @gertvdijk, you are making assumptions here which are not backed by facts yet - we don't know what happened on the system. – guntbert Jun 23 '13 at 11:24
9

Also check value of PasswordAuthentication in /etc/ssh/sshd_config and if it's no change it to yes. Don't forget to restart ssh service after that.

  • 1
    The OP is not trying to use password authentication. They have some sense and are using public/private key. – ctrl-alt-delor Aug 20 '18 at 17:43
7

Also make sure that the user's home directory (on the server) actually belongs to the user ssh'ing into (was set to root:root in my case).

Should have been:

sudo chown username:username /home/username;
  • I am able to ssh with public/private keys with a user on my local linux box (e.g. abc), different from the user on the remote server (e.g. def@123.456.789). I just had to make sure the local user owned the local .ssh files (e.g. abc:abc, not root:abc)` – Michael Dec 22 '15 at 9:44
  • This worked in my case – Zerquix18 Jul 14 '16 at 22:53
6

The problem I had was it was using the wrong keys on the client. I had renamed id_rsa and id_rsa.pub to something else. You can either rename them back to their default, or when you issue the ssh command, use it like this

ssh -i ~/.ssh/private_key username@host
  • 1
    no, use the public key – St3an Dec 3 '18 at 9:58
  • @St3an you put the public key on the server, but when you connected like Todd is here above, you use your private key – Nathan F. Apr 10 at 21:50
  • @NathanFiscaletti you must never expose your private key, that's why it's private. The private key is used by your local ssh agent to check that you really give a public key that correspond to your private one. SSH agents between machines can then guarantee that users are who they pretend to be :-) – St3an Apr 11 at 8:26
  • Exactly. Which is why when you connect, you provide your private key to the ssh-client. The server stores your public key. The command in the post above is exactly how private keys are supposed to be used. – Nathan F. Apr 11 at 14:54
3

I ran into this issue recently with my web server.

I typically keep a list of authorized keys on all my servers in ~/.ssh/authorized_keys2. From my experience, sshd will look for ~/.ssh/authorized_keys or ~/.ssh/authorized_keys2 by default.

In the case of my webserver, the /etc/ssh/sshd_config had this line

AuthorizedKeysFile    %h/.ssh/authorized_keys

instead of

AuthorizedKeysFile    %h/.ssh/authorized_keys2

I applied the latter, restarted my ssh daemon, and solved my problem logging in with ssh using my pubkey.

  • Thanks a lot, this helped me figuring out that this line was completely commented out of the config! – Christian.D Oct 8 '18 at 8:45
2

Another possible cause could be with the AllowedUsers configuration in /etc/ssh/sshd_conf. NOTE: the list is space delimited (not comma delimited) as I learned the hard way.

AllowUsers user1 user2 user3
1

If all else failed, check that your login user belongs to the ssh's AllowedGroup. That is, your users is a member of the group shown at the following line in /etc/ssh/sshd_config on the server:

AllowGroups ssh #Here only users of 'ssh' group can login
1

I my case, the client is ubuntu 14.04lts, the server was win 2012 server running cygwin. I was using 'ssh administrator@x.x.x.x', when the 2012 server directory in cygwin was /home/Administrator. So it was case sensitive, when I tried 'ssh Administrator@x.x.x.x' (note the capital A on Administrator) then it worked fine.

An error message like 'user not found' would have led me to the solution a lot quicker than 'Permission denied (publickey,keyboard-interactive)'.

  • Someone should log an issue with the ssh project suggesting that. I ran into a similar issue. – Ben Creasy Nov 27 '16 at 11:58
1

I had the same issue when copying a regular user's (e.g. johndoe) public key from a cPanel Centos system over to an Ubuntu server on AWS. As suggested by gertvdijk above, I checked /var/log/auth.log and sure enough it said Authentication refused: bad ownership or modes for directory /home/johndoe. Turns out I had wrongly 777'ed /home/johndoe when trying to set /home/johndoe/public_html as the default virtualhost Document Root for apache2 (that's not needed for that task either).

See also the answers here and here

The server only needs to have the public key in .ssh/authorized_keys and the client (computer you're working on) needs to have the private key (.pem, or if using SFTP with Filezilla, .ppk)

1

For those Putty users like me who came to this thread, you may also get this error if you forgot to add user user@Ip !

Others being permission on key file chmod to 600)

ssh 1.1.1.1 -i /path/to/.pem file 
Permission denied (publickey).`

ssh user@1.1.1.1 -i /path/to/.pem file 
1

This is what worked for me, the fix is not mine but I would rather write it down here in case someone else has the same problem.

The original author posted it here: digital-ocean-public-access-key-denied

sudo nano /etc/ssh/sshd_config

Replace this

UsePAM yes
IgnoreUserKnownHosts no
PasswordAuthentication no

With this

UsePAM no
IgnoreUserKnownHosts no
PasswordAuthentication yes

Save the file and restart ssh

reload ssh

ssh should work now asking for a password

1

I had the same problem as described in the question. The output from executing ssh -vvv -i id_rsa [youruser]@[yourLinode] on the client machine was similar to that described in the question. I checked all the file and directory permissions as advised in the other answers, and they were correct.

It turned out that when copying the generated file id_rsa.pub to the server machine, as file ~username/.ssh/authorized_keys, I'd accidentally omitted the word ssh-rsa from the start. Adding it solved the problem.

1

Works on Ubuntu 16.04 as well.

The issue is within sshd_config file

Here is the ULTIMATE solution:

Log as as a root to you Ubuntu server

vi /etc/ssh/sshd_config

Now go to very bottom and change the value from "no" to "yes".

It should look like this:

Change to no to disable tunnelled clear text passwords

PasswordAuthentication yes
service sshd reload

to take effect.

Now you can simply a key using following command from your LOCAL machine (aka laptop etc)

So Open new terminal window and do NOT log into server, simply put this command:

ssh-copy-id john@serverIPAddress

(Replace john with your username).

you should be go to go

0

In my case the issue was caused by copying over an .ssh directory from an older machine. Turns out that my older SSH config was using DSA keys which have since been deprecated. Switching to a new pair of keys, this time RSA-based, solved the problem for me.

0

The following method might work if you can access machineA and machineB independently (e.g. from machineC).

If ssh-copy-id is not working, password authentication could be disabled. The following is a workaround.

Having machineA's public key in machineB's authorized keys (i.e. ~/.ssh/authorized_keys) will allow you to ssh from machineA. This also applies to scp.

After generating the key pairs using: ssh-keygen

On machineA, execute cat ~/.ssh/id_rsa.pub

Sample output:

ssh-rsa AAAAB3NzaSGMFZW7yB anask@mahineA

Copy the printed key (⌘ Command+C, or CRTL+C) then add it to the ~/.ssh/authorized_keys file on machineB.

For example, execute the following on machineB:

echo 'ssh-rsa AAAAB3NzaSGMFZW7yB anask@mahineA' >> ~/.ssh/authorized_keys

0

Some people wondering may have set up ssh access to be key only on the root account then created a new user and not realised they need to

ssh root@your-ip-address

rsync --archive --chown=[user]:[user] ~/.ssh /home/[user]

logout

Then try again. Replace [user] with your new user account.

This is common when setting up a new server on DigitalOcean when you've used ssh-keys on setup.

https://www.digitalocean.com/community/tutorials/initial-server-setup-with-ubuntu-18-04

protected by heemayl Aug 4 '18 at 0:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.