13

I am trying to install ZTE MF191 driver in ubuntu 12.04 64 bit machine. I am not sure is it support 64 bit or not. But it works fine in 32bit system. These driver package has a executable file named zr When i try to run this it throws an error

libusb-0.1.so.4: cannot open shared object file: No such file or directory

I googled it but can't find a way to install(lib) it. Some people suggested to install 32bit version but i can't find one in synaptic. Please help.

20

To install the 32-bit version, run:

apt-get install libusb-0.1-4:i386

This only works if MultiArch is enabled (maybe it doesn't if you upgraded from an older Ubuntu version). Look for foreign-architecture i386 in /etc/dpkg/dpkg.cfg.d/multiarch to check if MultiArch is enabled, and if it doesn't, run echo "foreign-architecture i386" | sudo tee /etc/dpkg/dpkg.cfg.d/multiarch to enable MultiArch and apt-get update to get the new package lists.

6

to install libusb use sudo apt-get install libusb-0.1-4

2
5

It failed for me even after sudo apt-get install libusb-0.1-4:i386/sudo apt-get install libusb-0.1-4 so I did sudo apt-get install libusb-dev and it worked fine on my Ubuntu 64bit system

1
  • Had the same issue, your solution worked for me, thanks. – Mtl Dev Sep 18 '18 at 18:53
0

This error still exists in Ubuntu 18.04 LTS; my workaround was to install libusb-dev. This resolved it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.