So, I've installed Ubuntu server 12.04 LTS because of it's minimal processor/memory usage on a former compute node that I've repaired. My goal is to get it connected to my home internet through my cable modem/ethernet so that I can install the various packages I need to compile and run my particle simulation packages. Unfortunately, I have tried the standard approaches given on several forums including this one, and I have not been successful.

I am very much a novice/absolute beginner at all of this, so I appreciate all of the time and help!

Here is what I have tried thus far:

sudo ifconfig eth0 up

Then I edited the network interface file so it looks like this:

#The loopback network interface
auto lo
iface lo inet loopback

#The primary network interface -- use DHCP to find our address
auto eth0
iface eth0 inet dhcp

Now I execute this:

dhclient -r

sudo /etc/init.d/networking restart

For which I get this:

*Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces
*Reconfiguring network interfaces...
ssh stop/waiting
ssh start/running, process 1355

Then when I try to ping google:


I get nothing displayed....

Now, when I run:

route -n

I get...

Kernal IP routing table 
Destination    Gateway       Genmask        Flags  Metric  Ref    Use   Iface         UG     100    0      0     eth0   U      0      0      0     eth0

I very much appreciate any help that you can give me!

Thank you,



To me sounds like cable problem. Other problems could be port plugged into on either the switch or the computer has a problem. Final cause might be the ethernet card.

Is your ethernet card support by the version of 12.04 LTS? Be sure to try the latest revision 12.04.2 LTS to be sure.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.