I'm trying to do a dual boot on my Dell Inspiron 14z notebook, but I always get a black screen after selecting Install Ubuntu.

I've tried to add nomodeset and acpi_osi="Linux" to the boot options, but it doesn't change anything.

The hardware:

  • 3rd Generation Intel® Core™ i7-3517U processor (4M Cache, up to 3.0 GHz)
  • 8GB2 Dual Channel DDR3 SDRAM at 1600MHz
  • 500GB 5400 RPM SATA HDD and 32GB mSATA SSD
  • AMD Radeon HD7570M 1GB

This question isn't duplicated. I've already tested all tips in the following question!

  • 1
    Add details on graphics chipset. – david6 Jun 21 '13 at 20:24
  • Please can you do an md5sum on your install CD to check its validity. Also can you confirm is this a recent ISO download from ubuntu.com? askubuntu.com/a/301261/14356 – fossfreedom Jun 26 '13 at 13:06
  • @fossfreedom, I've already checked md5sum and I using the last ISO from ubuntu.com – Rodrigo Jun 26 '13 at 13:21
  • 2
    @Rodrigo - in your bios do you have an option to use the internal built in graphics adapter - if so try this. – fossfreedom Jun 26 '13 at 13:29
  • Have you tried selecting the option "Try Ubuntu without installing"? – Rodrigo Martins Jun 28 '13 at 14:54

Try booting Ubuntu without UEFI or Secure Boot. After that, you should be able to install it. If not, boot to the live CD (Try Ubuntu without installing) instead and install from there. Once you have installed, you may not be able to boot Ubuntu. Run this code from a live CD:

sudo apt-get install boot-repair
sudo boot-repair

Choose the recommended repair and follow the instructions boot-repair gives you, then reboot. You should be able to boot into Ubuntu.


I Have the same model And is working fine for me. Enter in the BIOS And change boot option from UEFi to LEGACY with the boot in your DVD or USB. Thats all.


I had the same problem when I was installing the Ubuntu 13.04 at my Inspiron 14z. You've to change the configuration on BIOS. Enter UEFI to LEGACY and change the boot device that you want to start in your laptop.

That's right here.


I will answer a bit silly but this happened to me and I felt silly when I discover it.

Did you try to hit the Fn + > arrow key to see if is just a low brightness issue ?


Try if it is possible to switch off the 3D function of your card. If yes switch it off temporarily to proof that this is not the cause of the problem. If this helps, try to update display drivers.


I see that you got a lot of answers, so I want to give you my 2 cents.

The AMD Radeon HD7570M graphics card that you have, is fairly new, and I don't think that 12.04 have drivers for it included in the ISO.

I would recommend that you download the Alternate install CD, 32bit version, or 64bit version. finish the installation, then load the graphics drivers, and I think that should do it.

Or just try installing 13.04.

You can get the driver Here.


I've set the BIOS defaults, including Boot Secure. It worked. Boot from pendrive, created with unetbootin.

  • it didn't work until I set Boot Secure on. – Capi Etheriel Dec 5 '13 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.