The issue at hand

My aim is to enable natural scrolling on system start (or session start), which - up until now - could be easily achieved using a startup script, but since migrating from 12.04 (32 bit) to 13.04 (64 bit) I'm not able to automate this task.

Here's the script used:

xinput set-prop 12 273 -25 -25

it works when running independently, so it seem to be overridden by a later call. How to resolve this?

What have I tried?

  • Adding an entry in the Startup Applications for the trackpad script
  • Using a @reboot flagged entry in crontab to call the xinput command
  • Calling the trackpad script in .bash_login, or in .profile
  • Adding a .conf file in /etc/init
  • I think at some point I even tried to mess around with sequencing directories and sequencing file names under /etc/rc*
  • Including a call in various scripts under /etc/pm (that actually got things working for the boot phase, but any subsequent suspend/sleep would deactivate the trackpad custom settings, again).


Dell XPS 13, Ubuntu 13.04 64 bit.

  • Do you have any finger scrolling enabled? That might interfere with your script. – Seth Jun 23 '13 at 18:10
  • nop. it's not the two-finger scroll, thanks for the attempt. – Eliran Malka Jun 23 '13 at 20:09
  • Are you sure? Check System settings > Mouse & Touchpad: jabstaboops.andthesethygifts.com/wp-content/uploads/2013/02/…. There are new options in this sense in Ubuntu 13.04. – Radu Rădeanu Jun 25 '13 at 21:04
  • yes, i am sure. – Eliran Malka Jun 26 '13 at 1:18
  • I don't want to affront you, - is this trackpad of Dell too ?! - because Logitech is supporting Linux now (they announced this one month ago). And there are trackpads of Logitech too. – dschinn1001 Jun 26 '13 at 22:21

This doesn't explain why it is happening, it's just a workaround.

You could automatically reset the property whenever it changes. Use this script:

while true; do
  xinput list-props 12 | grep -q "Synaptics Scrolling Distance (273):.*-25, -25" || xinput set-prop 12 273 -25 -25
  sleep 5
  • that's great, man. i was thinking along these lines (i.e. having a sleep once to avoid override by other scripts on startup), but it seems too dirty a solution. still it's the only thing that works for now. thanks – Eliran Malka Jun 28 '13 at 16:22

I recently installed Ubuntu 13.04 on a Dell Inspiron 17R, and my touchpad was only recognized as a PS/2 mouse. I found a post on the Ubuntu Forums that contained a custom driver to enable the touchpad features. Once I installed it, Ubuntu's System Settings > Mouse and Touchpad settings listed the touchpad options. And then a post on how to enable Natural Scrolling using dconf-editor. I hope this helps.

  • 1
    this is hardly related to the issue, my trackpad is working fine, and i can configure natural scrolling with no particular problem. the problem i'm having has to do with startup scripts, please read the question thoroughly before posting an answer. – Eliran Malka Jun 27 '13 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.