I am trying to dual-boot a brand-spanking new rebuilt computer. I bought (2) 128GB Samsung 840 pro SSDs with the intent of installing Windows 8 (new) on one and Ubuntu on the other... with a 500gb HDD for data storage. The Windows 8 install went super smooth... but Ubuntu is giving me fits.

My previous machine also was a dual-boot (Windows XP on one 250gb HD and Ubuntu on another), so I'm relatively familiar with dual-booting a machine from 2005... cannot figure out what's causing the problem here.

So I downloaded the ubuntu-12.04.2-desktop-amd64.iso file and wrote it to a blank dvd (using Windows 8). I also created a bootable usb drive of the same image. I have tried both, but am having similar problems.

The boot disk will allow me to start the install but it hangs on the "Where are you?" screen. The clock cursor still moves, and I can click on the map to highlight different areas... but as much as I click "continue", nothing happens.

I have also booted into the desktop using "Try Ubuntu without installing", and tried to install from there... install stalls out at the same place, with the clock spinning. I can, however, still navigate on the desktop and use the internet, etc.

A couple items that may or may not be of importance:

  • I am using the UEFI install option from my BIOS to get this far. I'm not sure that I understand the whole UEFI thing (being stuck back in 2005), but I think that it makes sense because I'm trying to dual-boot with Windows 8.
  • I am using the "Something Else" option from the Ubuntu installer, as I didn't want the "Install along side Windows 8" option to automatically throw Ubuntu on the same SSD as Windows. I partitioned the 128gb Ubuntu SSD as follows:
  • /boot = 500mb
  • / = 15gb
  • /home = 108gb
  • Swap = the rest (a bit over 4gb)

Some detail of my new system:

  • AMD A10-6800 Quad-core processor
  • ASRock FM2A85X Extreme6 Mobo
  • 8gb RAM
  • (2) 128gb Samsung 840 Pro SSDs... with Windows 8 installed on one
  • (1) 500gb HD - Data drive from my old installation. Not bootable.

I'm not sure what other info I can provide that would be helpful. I'd be very appreciative of whatever help y'all can offer... and will answer what questions I can.


  • Based on Karel's reponse, added Mobo info. I have been able to find very little info on the ASRock website about Power settings to accommodate SSD vs HD. However, Windows 8 is working very well on an identical SSD. Would also like to mention that the "Copying Files" progress bar at the bottom of the "Where Are You" screen does progress through 100%, but spinning cursor remains (though quite mobile and functional elsewhere) and does not allow me to click "continue".
    – Erin
    Jun 21, 2013 at 13:08
  • OK, I get it, so let me point you to the AnandTech hardware forum post on systems with multiple SSD/HDD hard drives AHCI Vs. RAID by andrewboon. Read down to the bottom of the thread. All of the answers to this question are worth reading.
    – karel
    Jun 21, 2013 at 13:16
  • That was and interesting read Karel... and gives me a few ideas to try. Right now, I beleive that the BIOS is set up in AHCI mode... and if I remember correctly, the SSDs show up in the BIOS boot list as "AHCI Samsung...". At this point, my goal is to have Windows 8 OS and some apps on one SSD and Ubuntu OS and apps on the other SSD. I do forsee a time when I would like to RAID 1 a couple of HDD for data, so it may make sense to change from AHCI to RAID now. I'm not sure whether this will solve the problem at hand, but I'll give it a try tonight. Will probably mean reinstalling Windows 8.
    – Erin
    Jun 21, 2013 at 13:37
  • Changing the BIOS settings from AHCI to RAID worked for me with a multiple SSD/HDD system with a different motherboard booting only Ubuntu. I don't even use RAID, but it worked anyway. I don't know what if any effect this would have on Windows 8. That would be a good question to ask on the Superuser Q&A website.
    – karel
    Jun 21, 2013 at 13:55
  • Quick response from coffee shop. I changed the Sata mode from AHCI to RAID and attempted a fresh install of Windows 8. The install errored out, and I was unable to get Windows installed. I eventually switched back to AHCI and installed Windows. I still cannot get Ubuntu to install on the second SSD... hangs in same place as mentioned in original post. {shrug}
    – Erin
    Jun 22, 2013 at 18:16


You must log in to answer this question.

Browse other questions tagged .