It has been a long time since I last tried, but Rhythmbox won't play the radio stations that used to play perfectly well. I haven't tried for > 6 months. The station I want to hear is mms://s67wm.castup.net/990310008-52.wmv, but no other station works either.

If I run it under VLC, it works fine. It could be that I used Banshee long ago which was replayed by rhythmbox - I simply don't remember.

My question is: can anyone verify that rhythmbox does indeed play radio stations? The advantage of rhythmbox is that it doesn't take any extra space on the icon bar, since it is always running. I like the idea of being completely unobtrusive, and it used to work beautifully.

Thanks, Ilan


While trying to play a station, you've got to enter this into a terminal:

sudo killall gvfsd-http

... And you should be OK. The "sudo" part will require you to input your password. Hopefully, we'll all laugh about this later. And yes, you'll have to do this each and every time, for each and every station. It's a bug.

  • 3
    If this is a recognized bug, would you please include a link to it in your answer? – gertvdijk Jul 14 '13 at 23:28
  • Thanks for the answer, but I can't get it to work. I did the sudo command (copy and paste), but it won't play. What I see is a bar moving back and forth in an object on the status bar. It is as if it is searching for the station but can't find it. Then I fired up VLC with the same url and VLC works fine. Maybe I have to kill something else as well? – Ilan Jul 16 '13 at 4:14
  • An addition to my comment: I tried a different radio station, one with a http header and that DOES work. I tried gvfsd-mms and as expected the system doesn't know what gvfsd-mms means. So we are halfway there. Before the bug ALL stations worked. – Ilan Jul 16 '13 at 4:21
  • 1
    The bug URL is bugs.launchpad.net/ubuntu/+source/gvfs/+bug/1153934. – colan Jul 22 '13 at 15:12
  • I got it working! Thx (I know we should no longer remain on 13.04 now that's EOL). Still I sometime get Internal Data Flow Error but relaunching Rhythmbox seems to resolve it. – IsaacS Feb 20 '14 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.