My last installation of Ubuntu 12.04 on a machine using an ASUS Q87M-E motherboard with an Intel I217LM Ethernet controller has failed to detect the ethernet card. The only thing displayed by

ifconfig -a

is the loopback. I double-checked in the BIOS, and the controller should be online.

$ rfkill list all
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

$ lspci

00:00.0 Host bridge: Intel Corporation Haswell DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Haswell PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Haswell HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation Lynx Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Lynx Point MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation Lynx Point KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation Device 153a (rev 04)
00:1a.0 USB controller: Intel Corporation Lynx Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Lynx Point HD Audio Controller (rev 04)
00:1d.0 USB controller: Intel Corporation Lynx Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Lynx Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Lynx Point 6-Port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation Lynx Point SMBus Controller (rev 04)

$ lsmod

Module                  Size  Used by
vesafb                 13844  1
snd_hda_codec_realtek   224173  1
arc4                   12529  2
joydev                 17693  0
usbhid                 47238  0
hid                    99636  1 usbhid
rfcomm                 47604  0
rt73usb                31735  0
crc_itu_t              12707  1 rt73usb
rt2x00usb              20808  1 rt73usb
rt2x00lib              55326  2 rt73usb,rt2x00usb
mac80211              506862  2 rt2x00usb,rt2x00lib
cfg80211              205774  2 rt2x00lib,mac80211
eeepc_wmi              13109  0
bnep                   18281  2
asus_wmi               24456  1 eeepc_wmi
sparse_keymap          13890  1 asus_wmi
psmouse                97485  0
bluetooth             180153  10 rfcomm,bnep
ppdev                  17113  0
snd_hda_intel          33719  6
snd_hda_codec         127706  2 snd_hda_codec_realtek,snd_hda_intel
snd_seq_midi           13324  0
snd_hwdep              17764  1 snd_hda_codec
snd_rawmidi            30748  1 snd_seq_midi
serio_raw              13211  0
snd_pcm                97275  2 snd_hda_intel,snd_hda_codec
snd_seq_midi_event     14899  1 snd_seq_midi
snd_seq                61929  2 snd_seq_midi,snd_seq_midi_event
snd_timer              29990  2 snd_pcm,snd_seq
snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
parport_pc             32866  1
snd                    79041  21 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_rawmidi,snd_pcm,snd_seq,snd_timer,snd_seq_device
video                  19651  0
soundcore              15091  1 snd
wmi                    19256  1 asus_wmi
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
mac_hid                13253  0
lp                     17799  0
parport                46562  3 ppdev,parport_pc,lp

$ ifconfig

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1091 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1091 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:80048 (80.0 KB)  TX bytes:80048 (80.0 KB)

wlan0     Link encap:Ethernet  HWaddr 00:fd:07:91:a8:b9
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::2fd:7ff:fe91:a8b9/64 Scope:Link
          RX packets:56644 errors:0 dropped:0 overruns:0 frame:0
          TX packets:36417 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:85270918 (85.2 MB)  TX bytes:3413849 (3.4 MB)

additionally, running

sudo lshw -C network


*-network UNCLAIMED
  description: Ethernet Controller

I'm pretty stumped at this point. This doesn't sound like a very uncommon ethernet controller and I figured it would be picked up by the system.

Does anybody have advice for how to deal with this? Anything specific I should look into to figure out what could be causing this?


It seems that following the guide on the Intel e1000e drivers page allowed the card to start working. Is this a real fix or is there a better way?

  • Can you run an "ifconfig" and post the output of it? – user101351 Jun 20 '13 at 4:24
  • Of course, updated the post with the output. – Alexandr Kurilin Jun 20 '13 at 4:34
  • Oh boy.. run an "rfkill list all" and tell us the output. – user101351 Jun 20 '13 at 4:38
  • Updated the post with rfkill list all! Please note that the wireless controller is just a usb dongle I'm using right now to "bypass" not being able to connect through the wire. – Alexandr Kurilin Jun 20 '13 at 4:57
  • Mm.. Ubuntu doesn't detect it yet it does.. are there any other OS's on the machine to test the Ethernet with? – user101351 Jun 20 '13 at 5:02

This appears to be a real fix.

I had the same problem today and found the explanation: support for Intel I217 is available since linux kernel 3.5 (commit). As Ubuntu 12.04.2 uses kernel 3.2.x, the Ethernet card is not recognized and cannot work.

I followed your advice and installed the e1000e driver from the Intel e1000e drivers page and it worked perfectly. From there I was able to upgrade the linux kernel.

  • That's awesome, thank you for investigating this further!! I was still puzzled about what was going on there until your explanation. Hopefully this is of help to people stumbling into the issue in the future. – Alexandr Kurilin Jul 3 '13 at 18:31
  • So this ethernet I217 worked with e100e driver just fine? I cannot upgrade kernels due to software limitations, and I need to use a new system with this hardware. – dbbd Dec 16 '14 at 13:07
  • @dbbd Once I installed the e1000e driver from the Intel site, it worked perfectly. I could continue to use this configuration (not upgrading the kernel) but I needed to upgrade. If you follow instructions on the e1000e page to compile the driver and load it, it should work as expected without upgrading the kernel. – cbliard Dec 16 '14 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.