OS - Xubuntu 13.04 64-bit fresh install (up to date)

I'm trying to install the ati/amd graphics drivers for the laptops dedicated graphics card, but im having a really hard time.

I followed the Ubuntu_Raring_Installation_Guide on a fresh install (packages up to date). The installation seems to go fine. But when I reboot this happens.

Note. I followed the Ubuntu_Precise_Installation_Guide on 12.04 LTS 64 and that worked fine testing fglinfo and the gears test all worked well. So then I updated that to 12.10 that worked fine too. I should have gone on to 13.04 with the update but I pushed my luck and went a fresh install of 13.04 and then struck problems again.

*Update 1. Installed Xubuntu 12.10 64 and followed Ubuntu_Quantal_Installation_Guide it needed libqtgui4 but the driver works fine.

*Update 2. Updated Xubuntu 12.10 64 to Xubuntu 13.04 64 same problem as fresh 13.04

Only seen this error once, after second install I didn't get it just boots saying * startingand nothing else. enter image description here

Is this a bug cause by me? or Ubuntu or AMD? Where do I point the finger?

How do I construct a useful bug report for this issue?

Dell Vostro 3560, i7-3632QM, AMD Radeon HD 7670M 1GB

Bug report. https://answers.launchpad.net/ubuntu/+question/231272

Related ? http://forums.gentoo.org/viewtopic-t-949372-start-0.html

  • 1
    could you post the contents of Xorg.conf file? – Misery Jun 20 '13 at 7:20
  • The error in the picure shows an ATA error (storage controller in frozen state). This has nothing to do with the graphics driver. I think you're running into a kernel bug for the kernel with 13.04 which only appears after installation because during installation it downloads a newer kernel. Please file a bug report: askubuntu.com/questions/5121/how-do-i-report-a-bug – gertvdijk Jun 23 '13 at 10:00
  • In that case I think I will just go back to 12.04 and live with that. I've submitted reports in the past that have not been dealt with. I can't afford to waste any time here +I have no idea what I am reporting. Are you saying that If I do a fresh install of 13.04 and install the required libs it will crash like that ? – Andy Jun 23 '13 at 10:24
  • 1
  • 1
    When I reinstalled 13.04 again I didnt get that error with the ata controller again. Is this related.. the error from X is just about the same as this forums.gentoo.org/viewtopic-t-949372-start-0.html Could have been a bad install maybe? – Andy Jun 24 '13 at 13:30

Post the information you have here (https://answers.launchpad.net/ubuntu/+question/231272) and the Xorg/Xserver logs on the bug report form that can be found here https://launchpad.net/xorg. Include the kernel and Xubuntu version as well as your hardware information (graphics card, processor, etc.). If the Xorg developers need any other information, they will ask. You may also consider reporting the bug to the Xubuntu developers (https://launchpad.net/xubuntu-desktop) if the Xorg developers are not sure about the issue.
This link may help you - How do I report a bug?.

  • That first link is my bug report... I haven't had anything back from them yet :/ – Andy Jun 28 '13 at 14:17
  • Your first link goes to the questions and answers portion of LP. That is not an official bug report. – Devyn Collier Johnson Jun 28 '13 at 22:00
  • 1
    Ah.. that would explain that. Thanks. I didn't really read ur answer very well. So do you think Xorg is to blame? U didn't know if it was something with the AMD Driver – Andy Jun 29 '13 at 10:27
  • @Andy, it may be a driver, but usually Xorg is the cause of problems. – Devyn Collier Johnson Jun 29 '13 at 19:14
  • 1
    I think i'm with you on that, or at least something in ubuntu/linux. I mean the same driver worked fine on 12.04. I posted the bug you xorg but ive not had anything back. – Andy Jul 3 '13 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.