0

I have built myself a new server/pc. I happened to installed a WiFi card that was not supported by ubuntu 12.04 lts, so I found drivers that worked and all was good for some time. After the kernel update I rebuilt the drivers with no success, so I ran the live CD of 13.04 and the WiFi worked cool. I then did the upgrade to 12.10 and finely to 13.04 but the WiFi is still not working. Any suggestions?

lspci

Network controller: Ralink corp. RT5360 Wireless 802.11n 1T/1R


sudo lshw -C network

*-network UNCLAIMED
description: Network controller
product: RT5360 Wireless 802.11n 1T/1R
vendor: Ralink corp.
physical id: 6
bus info: pci@0000:03:06.0
version: 00
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: latency=32 maxlatency=4 mingnt=2
resources: memory:fd3f0000-fd3fffff 
  • Does it start working if you open a terminal and do: sudo modprobe rt2800pci If so, we can make it permanent. If not, check the logs for error messages: dmesg | grep rt2 – chili555 Jun 19 '13 at 19:11
  • thanks chili555. sudo modprobe rt2800pci worked, how can we make it permanent. – user168595 Jun 19 '13 at 19:18
1

Please open a terminal and do:

sudo su
echo rt2800pci >> /etc/modules
exit

You should be all set but feel free to post back if you need additional guidance.

0

Since Ubuntu has been facing issues with Ralink wireless drivers from 12.04. I have also faced that issue in Ralink RT3290 after switching from Unity to GDM (Ubuntu 16.04)

One easy and quick solution is

  1. Delete /etc/Wireless (using sudo rm -rf /etc/Wireless)
  2. Use your live USB (bootable Ubuntu) and boot from it, and "Try Ubuntu" in boot option.
  3. In my case after booting live USB, I have connected the internet using USB tethering from my mobile device which is optional that I don't think should make any difference.

Also add

http://ppa.launchpad.net/hanipouspilot/rtlwifi/ubuntu xenial main
http://ppa.launchpad.net/hanipouspilot/rtlwifi/ubuntu xenial main (Source code)

in Other Software of Software & Update and check them.

took hardly 5 minutes to execute. Kind of illogical but worked.

Worked well for me!

Tell me if it worked.

  • I don't see a Wireless directory in /etc, though I don't have a Ralink card and I'm using Unity. – wjandrea Jun 13 '17 at 16:28
  • @wjandrea this thread is for Ralink wireless hardware.I can afford only one laptop to explore my hardware knowledge. Had to be saved somewhere in /etc, I am using Ubuntu 16.04 LTS. Still i will explore for other hardware and guide you through it – Abhilash Gupta Jun 15 '17 at 6:50
  • Following my procedure will lead to restore basic driver of Ralink wireless i.e. Rt 2860/Rt2870, which had been compatible to most of the wireless hardware manufactured my Ralink. – Abhilash Gupta Jun 15 '17 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.