2

When using Nautilus and right-clicking on a file > Properties, user is presented with a permissions tab. The default UI for this permissions tab is horribly difficult to understand and calibrate and lacks any sort of user-friendliness. Accordingly, I need Nautilus to display the alternate view: what has always been called "advanced-permissions" view. Here is what the "advanced-permissions" look like: enter image description here

using dconf Editor I have always been able to go to setting dconf-editor > org > gnome > nautilus > preferences > show-advanced-permissions and change the appearance of the permissions to this "advanced" presentation which makes the permissions much easier to understand and calibrate.

So how do I get Nautilus to display what has always been called "show-advanced-permissions"? Why is this setting missing from 13.04? How do I get it back?

  • A functional problem with not having "advanced permissions" view is that there is no GUI way of giving only the file Owner Execute-capability. Without the "advanced permissions" view, setting Execute on a file necessarily means giving Execute-power to 1)Owner, 2)Group, and 3)Others--something that is not only frustrating but also a security risk. With "advanced permissions" view, Execute can be assigned to only the 1)Owner. – Greg Jun 19 '13 at 14:18
2

The advanced permissions mode in Nautilus was removed from August 2012.

Remove advanced permissions

This mode is worse than useless because it is impossible to find, it complicates the ongoing maintanence of the dialog, and if there is important configuration in it we should be offering it by default without a special hidden mode.

Source: index : nautilus - Commit message: Remove advanced permissions

  • Is there any chance it will be back? – Hibou57 May 1 '15 at 11:30
0

Not sure if this will work on 13.04 but try this:

While still shown in gconf nautilus, settings are now handled through dconf. Install dconf-tools using sudo apt-get isntall dconf-tools on a terminal, then open dconf-editor & browse to org > gnome > nautilus > preferences

Or use gsettings as:

gsettings set org.gnome.nautilus.preferences show-advanced-permissions true
  • Unfortunately, it does not work with Ubuntu 14.04. – Hibou57 May 1 '15 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.