The Dropbox process constantly clocks more than 50% CPU usage sometimes going up to the higher 80s and 90s. At the same time it does not even upload/download the files it is supposed to. The progress is stuck at the same point and the dropbox daemon has not uploaded/downloaded more than one file in the last 24 hours. We are only talking about small files like pictures (~ 4-10 MB each). The effect this has on my laptop is that it overheats, sometimes with core temperatures up to 15-20 degrees above normal. The CPU utilization and temperature fall noticeably after I kill the dropbox daemon.

I have had this problem for more than a week now. I am using Xubuntu 12.04. I have more than enough local disk space available (8 GB in the disk where home and root are mounted) and 20 GB free space in my Dropbox account. I have 2 GB RAM.

I have also tried the following process (mentioned in this question: Dropbox is taking too much CPU time. How can I fix it?):

sudo apt-get purge nautilus-dropbox
rm -r $HOME/.dropbox*
sudo apt-get install nautlius-dropbox

But it made no difference to the problem at hand.

  • Have you check your Internet connection? Commented Jul 9, 2013 at 15:24

5 Answers 5


First run in a terminal:

sudo apt-get install cpulimit && sudo apt-get update

Then use a text editor like gedit or kate and put the following text in the file.

dropbox start -i
cpulimit -e dropbox -l 15

save the file with a name like "cpulimit.sh." After saving go to the icon and right click, somewhere in the permissions section, there will be a box for "make executable" or something similar. Check that box. Go to the autostart program, which you can find by typing "startup" in unity ubuntu or autostart in kubuntu. Add a program, browse, find the .sh file you made and set ok. It should run every time you boot up. In the code above you'll notice there is a '15' that is the cpu useage max. You could probably set it even lower if you want (eg replace '15' with '8' or whatever). I don't know if there is a minimum or not.


My situation might be different from yours, but I was having the exact same problem, however I'm now at a point where my Dropbox is working correctly.

Two things may have been a factor in getting my Dropbox into a working state.

First, specifics of the reinstall. For good measure I started with:

rm -r ~/.dropbox*

Next, I followed the instructions here: http://www.computeractive.co.uk/ca/computeractive-blog/2186872/fixing-dropbox-ubuntu-1204


sudo apt-get clean
sudo apt-get update
sudo apt-get --purge remove nautilus-dropbox
sudo apt-get --purge autoremove
sudo apt-get --reinstall install nautilus-dropbox

Second, my situation might be different from yours in that I was trying to set Dropbox up on a secondary HDD since my primary HD is a smaller SSD.

I'd run into problems with Dropbox on secondary drives in the past, so as I was trying to troubleshoot the problem I always had it in the back of my mind that the issue could be related to trying to use a secondary drive.

After having no luck with the solutions you suggested here and others suggested elsewhere, I gave up and decided to see if it would behave more normally if I set my Dropbox up on the primary HDD.

I don't know if it was step 1 or step 2 that did the trick, but after that reinstall with my Dropbox folder on the primary SSH, Dropbox synced and behaved as expected.

Let me know if step 1 solves your problem, because I haven't looked into moving my Dropbox over to my secondary HDD, but I would like to.

Hope this helps!


Check dropbox filestatus. it hogs cpu and memory when someting goes wrong. in my case the problem was in teamviewer file structure.

Good luck!


I had the same issue and I fixed by

rm -r ~/.dropbox
ln -s /mnt/win/Dropbox ~/Dropbox

Replace /mnt/win/Dropbox with the path to the Dropbox folder from your secondary HDD. Now start the Dropbox and set the location to ~/Dropbox


I tried all the above but every time I re-installed it locked up one CPU core at 100%. Finally found if I followed all the steps to purge dropbox then did a clean install using the deb package from the dropbox website all runs fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .