I made a Ubuntu 13.04 64 bit USB drive, using that I installed Ubuntu onto the 1 terabyte hdd in the machine, thus erasing my windows 8 installation (I use Ubuntu on all of my computers and have always done this). After it finished installing it told me to reboot, I clicked the button to reboot and it succesfully did that.

The problem is when it is trying to boot up it does not seem to recognize my HDD as a place to boot from, it simply gives me an error stating that there are not valid boot devices. If I place a live USB in there though, it will boot fine off of that. Or if I go into the boot menu, it does not display the HDD as an option to boot from.

If it matters, I have reinstalled it twice now, and the Ubuntu installer did recognize that Ubuntu had been installed.

System Specs:

  1. AMD 6 core 3.5 ghz processor
  2. 24 gigabytes of ram (two 8 gb sticks and two 4 gb sticks)
  3. 1 terabyte HDD
  4. 128 gigabyte SSD (I was hoping to install Ubuntu on this, but mount /home on my HDD, but by now I just want a computer which boots up :/ )

I had the same problem when I try install Ubuntu in my Utrabook HP Pavilon (500 GB HDD, 32 GB SSD). I installed with USB drive

After try install some times, the problem to me is that I was not creating the boot loader partition.

The configuration that worked is

Before install:

  1. Disable the fast boot and the Secure Boot
  2. Enable the Legacy BIOS

In installation:

My partitions configuration are:

  1. HDD : /home, /boot, /boot/efi (boot loader), /swap
  2. SSD : /

After to install enable the fast boot. With this configuration, my Ubuntu installed with successful! Sorry my bad English :)
I hope I helped you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.