When I restarted my Ubuntu after it being updated, I found the Unity launch bar was gone.

I tried looking up several solutions online, blindly typing in the commands that others suggested, and I found after the umpteenth time rebooting after typing in another foreign command, I found I couldn't even open up the terminal with the Ctrl+Alt+t shortcut either and I have no idea how to fix this.

This was the last set of instructions I remember following before terminal stopped opening.

Install CCSM

sudo apt-get install compizconfig-settings-manager

And then run it in terminal (Ctrl+Alt+t)


Then search for "Ubuntu Unity Plugin". If it's not checked, check it.

If it is checked you may have another issue. Try restarting compiz:

kill -9pidof compiz`

This will kill it, it should start up again, if it doesn't, CTRL+ALT+F2 and then type:

sudo service lightdm restart

to restart the window manager. Go back to the terminal and run:

unity --reset


I just had exactly the same problem on Ubuntu 13.10. Unity launcher gone and ctrl + alt + t shortcut not working. I opened xterm by typing CTRL+ALT+F2 and tried unity --reset, but that did not work since it is deprecated in ubuntu > 12.10.

This solution worked for me:

  1. Log into unity.
  2. Right click on the desktop and create a new folder.
  3. Open the folder and go to /usr/bin and start gnome-terminal by clicking on it.
  4. Type ccsm in the terminal to start compiz config settings manager.
  5. Go to preferences -> plugin list.
  6. Uncheck the automatic plugin list. And enable all the plugins.
| improve this answer | |
  1. Right click on desktop and create new folder
  2. open folder and go to /usr/bin and double click on gnome-terminal
  3. type in sudo open unity and type in password

That shall be it

| improve this answer | |
  • It may be better/easier to run that command from outside of the current desktop session. You can change to an actual terminal with Ctrl+Alt+F1. – David Foerster Mar 4 '15 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.