1

I am attempting to copy mysql.jar.com.mysql.jdbc.Driver in the Java directory. I get a permissions error. I have administrative privileges so I don't know what the problem is. My feeling is that ubuntu archive manager should handle it but I can't get that to work either.

I am attempting to link a Libre Base application to a mysql host = 216.87.239*.206:3306/accouoj3_ISR

I don't know if I should be using a ODBC or JDBC with that particular host.

  • Can you give more information? You are trying to copy that file to where (which path?)? How are you trying to copy it (by terminal/Files application)? – Salem Jun 17 '13 at 20:19
  • I am attempting to link a Libre base as a front end to a hosted mysql database. I will design the forms, queries and reports in Base and link to the mysql tables. – Gerald Jansen Jun 19 '13 at 3:07
  • My problem is setting up the ODBC or JDBC. I have read that base has a native connector and that I don't need either. However, that doesn't seem to work either. – Gerald Jansen Jun 19 '13 at 3:08
3

You can add the driver going to "Tools" -> "Options" (in Libreoffice Base) and do the following:

enter image description here

You can place the JAR whenever you need (if you don't already have it get it here). You can create a new JDBC connection:

enter image description here

| improve this answer | |
  • boxes look nice ...i like it clean neat answer – Qasim Jun 19 '13 at 12:22
-1

If you install the driver as an add on in software centre, then:

Click on Class Path, Add Archive and Browse to /usr/share/java/mysql-connector-java.jar. Click Ok.

| improve this answer | |
  • if this jar file does not exist on your system just install package using command "sudo apt install libmysql-java" – Jiří Doubravský May 21 '17 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.