I did a fresh install of ubuntu 13.04 desktop on my machine from the mini.iso to alleviate the hours it would take to download the entire version (slow internet connection).

It all installed fine, though I feel like I missed some important packages. I installed kubuntu (unity is a hassle on my desktop, can't handle it), and rebooted. It booted straight into terminal (or whatever it's called, not a GUI). I have an old nVidia Quadro 560 as my GPU so I assumed it wasn't booting the GUI because there weren't any drivers installed yet.

So I updated all my packages and headers with

sudo su
apt-get update
apt-get install linux-headers-generic
apt-get install nvidia-current-updates

Rebooted, still launched into 'terminal', though this time the resolution was off (origionaly was correct at 1900x1200, now it's 800x600).

Don't really know what I missed, attempted startx in super user, and it was not recognized.

Again I feel like I did not install any GUI packages, though I don't know enough about linux to know what command/repository to grab these from. Unless I do have it and don't know how to get it to load.

Thanks for any help that's given, new to linux but not a complete novice at it.

(Note: I had had ubuntu 12.10 installed on this desktop, attempted to upgrade via Upgrade manager and I think it froze during the update causing errors. Attempted to fix this with apt-get update and it caused a kernel panic, of which I did not feel like fixing so I went this route with a fresh install).

  • in terminal try running startx and see if your gui starts. – To Do Jun 17 '13 at 16:44
  • I have, it does not recognize the command, which means I don't have a package installed. – Eric Jun 17 '13 at 16:48
  • How did you install kubuntu? Did you sudo apt-get install kubuntu-desktop? – To Do Jun 17 '13 at 17:30
  • No, it was an option in the mini.iso installation from a drop down menu. I was under the assumption I'd be able to tick off multiple boxes, though I wasn't. – Eric Jun 17 '13 at 17:49

The mini.iso does not install an X server.

At a minimum, you need sudo apt-get install xorg

Exactly what packages you need after that will depend on what was installed when you installed Kubuntu.

You may also need sudo apt-get install xserver-xorg lightdm.

  • Exactly what I was looking for thanks. Just didn't know the code. – Eric Jun 17 '13 at 17:51

Don't use the mini.iso; it simply delays downloading the packages until install time where it will go slower than just downloading the regular desktop iso in the first place.

When using the mini.iso, at the task selection screen you have to select a desktop environment if you want one. If you failed to do so, then you would need to do it now with sudo apt-get install ubuntu-desktop.

  • Do you know where to find the full ISO download? Looking at the website I see the option for the network download, – Cyle May 5 '14 at 21:23
  • @Cyle, huh? The web site guides you to the full download, to get the mini iso you really have to know exactly where it is, which is an entirely different download server... – psusi May 5 '14 at 23:13
  • Sorry I was in the middle of writing that comment and had not realized I had posted it - I also realized later on that the problem this guy is having is completely different from my own. – Cyle May 5 '14 at 23:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.