6

I have 13.04 64 bit Ubuntu installed and I'm using Unity Tweak tool to enable hot corners everything works as it should as long as I don't reboot as soon as I do hotcorners stops working. In order to get them functioning again I have to open the tweak tool and turn hotcorners off and then back on after every reboot. This I admit isn't a huge issue but is annoying is there anyway to get hotcorners to work properly after reboot with out having to reset them every time?

3
  1. Install dconf-editor:

    $ sudo apt-get install dconf-tools
    
  2. Run dconf-editor (don't use sudo as the changes wont affect your account)

  3. Navigate to org -> compiz -> profiles -> unity -> plugins -> core.

  4. Copy the field active-plugins into Gedit, and edit it so unityshell is the last item. Paste it back into dconf.

  5. Restart your computer.

(Tried on 14.04, it works.)

  • 4
    Mine already defaults to unityshell as last item, but problem still exists. – kolslorr Jun 11 '14 at 14:03
  • @kolslorr It could be that the "default" just sets it to the value it had on boot or something, I really wouldn't know. Could you check again? And try switching to the guest account - see if it has unityshell as the last one as well (remember not to use sudo). – jcora Jul 3 '14 at 13:33
  • solved my problem – Amir Oct 3 '15 at 8:47
0

Well this might help, If you set the right bottom hotcorner to spread all windows, it will work even after reboot. I guess its because that is the only corner on the screen Ubuntu does not get to use with default launchers.

  • It resets the right corner as well for me. (14.04) – jcora Jun 6 '14 at 7:29
0

in 14.04 for a work around what I did was write a bash script to set the hot corner edge valuse using dconf, but you will need to use dconf to find out what hot corner triggers you are using you need to install dconf-editor, using the tree-structure you can work out the paths.

#!/bin/bash
dconf write /org/compiz/profiles/unity/plugins/scale/initiate-edge "'|TopLeft'"
dconf write /org/compiz/profiles/unity/plugins/scale/initiate-all-edge "'|BottomLeft'"
dconf write /org/compiz/profiles/unity/plugins/expo/expo-edge "'TopRight'"
dconf write /org/compiz/profiles/unity/plugins/core/show-desktop-edge "'|BottomRight'"

For expo it didn't have | in front

Then I ran this automatically script after logging in.

-1

I've had mixed luck with this, which used to fix this reliably in 12.04: Scale plugin keeps forgetting hot corner settings on restart :

Run gconf-editor from Terminal or Alt+F2 Navigate to apps > compiz-1 > general > screen0 > options Edit the key: active_plugins Move "Scale" to the bottom of the list. Move "Expo" to bottom right above "Scale" and underneath Unityshell.

Try moving Expo to after Scale at the absolute bottom in 12.10+

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.