0

I am known about Ubuntu for quite a while but only a couple of months ago I started using it more often as my secondary OS.

Anyway, my problem is that the update manager keeps failing to install the 16 updates I have and I'm not sure why so I need some help from more experienced users. I have a Lenovo G575 Laptop with an AMD E300 APU 1.3Ghz and 4GB RAM.

Below is the message I get when the update has failed.

installArchives() failed: Preconfiguring packages ...
Preconfiguring packages ...
Preconfiguring packages ...
Preconfiguring packages ...
(Reading database ... 
(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%dpkg: unrecoverable fatal error, aborting:
reading files list for package 'libbonoboui2-0': Input/output error
Error in function: 
SystemError: E:Sub-process /usr/bin/dpkg returned an error code (2)
  • Input/output error seems to suggest some issue with that file or in mounting of the hard disk partition or some corruption of bits in the partition itself. Can you use some tool like GSmartControl and check the status of the hard disk? – nizar malangadan Jun 17 '13 at 12:13
0

Try this first:

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade

If that doesn't work, you might need to follow the instructions in the topic here: http://ubuntuforums.org/archive/index.php/t-1232143.html . The post by gartss might be useful to you.

|improve this answer|||||
  • Hello there @Gx1sptDTa I tried what you said and at the end I get this message. E: Sub-process /usr/bin/dpkg returned an error code (2) – Moe Jun 17 '13 at 12:59
  • I also looked at the link (Thanks for that), but i'm afraid still no luck, looks like I might have to reinstall : / – Moe Jun 17 '13 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.