11

I am new, never used Ubuntu until yesterday, so I'm not really into it, yet. I installed PhpStorm from JetBrains, but I can't find it anywhere, I need to run it. I searched /usr/share/applications as suggested in another post, but again, no success.

Please give a helping hand. Any terminal command or help with the location I could find it and make a shortcut on the desktop would be appreciated.

  • How did you install? – thefourtheye Jun 17 '13 at 11:05
  • According to the installation guide in the answer I worked with phpstorm a little bit and then closed it. Now I don't know where to find it – Mihai Bujanca Jun 17 '13 at 11:11
15

This tutorial can be helpful for what you need: Running PHPStorm.

Run the following commands in terminal:

cd /home/user/PHPStorm/PhpStorm-111.296/bin
chmod +x phpstorm.sh
./phpstorm.sh

You can create a shortcut on the Desktop by using gnome-desktop-item-edit in terminal as follow (note that if you don't have installed the package gnome-desktop-item-edit, you must be install first, so if you have gnome-shell or gnome-tweak-tool installed, then it is installed automatically):

gnome-desktop-item-edit --create-new ~/Desktop

This will start the dialog (Create Launcher):

enter image description here

Insert for Name any name you want (for example 'PHPStorm') and for Command sh /home/user/PHPStorm/PhpStorm-111.296/bin/phpstorm.sh and press Ok.

You can put this .desktop file in any folder, and then drag and drop to the Launcher.

Thanks to Binarylife for this answer.

| improve this answer | |
  • It is exactly what I did. But after I ran phpstorm, I closed it. Now I can't find it. I guess I don't always need to run that in order to launch PhpStorm after installation – Mihai Bujanca Jun 17 '13 at 11:11
  • Open again PhpStorm from terminal with this command: /home/user/PHPStorm/PhpStorm-111.296/bin//phpstorm.sh. After it will open, right click on it on Launcher and select Lock on Launcher. – Radu Rădeanu Jun 17 '13 at 11:24
  • I locked it to the launcher but it does not launch – Mihai Bujanca Jun 17 '13 at 12:05
  • @BujancaMihai I edited my answer, check now. – Radu Rădeanu Jun 17 '13 at 16:44
4

I faced similar problem. You can solve this as

1. First locate your phpstorm.sh using command:  locate -b phpstorm.sh
2. Copy these url
2. For Running phpstorm: sudo [paste these url] 
3. For solving this problem permanently use Radu Rădeanu's answer,given     
at top.
| improve this answer | |
1

A bit late to the party, but I had the exact same problem which brought me here, however I found the answer in this post.

The short answer which worked for me: open the terminal and type the following at the command prompt: locate -b WebStorm

| improve this answer | |
0

I located phpstorm and the starting script phpstorm.sh on my Debian Stretch system using this shell cmd:

sudo find / -name "phpstorm*"

Output:

...
/opt/PhpStorm-172.3968.35/bin/phpstorm.sh
...
| improve this answer | |
0

If the software is installed with ubuntu software center, its likely using snap and the downloaded src files can be found at /snap/phpstorm

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.