7

How can I replace PHP 5.3 with PHP 5.5 on Ubuntu 12.04? I searched with Google and failed to find a repository.

marked as duplicate by Radu Rădeanu, Alvar, Thomas Ward, Mitch, aquaherd Jun 17 '13 at 19:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

14

You can use my PPA with PHP 5.5: https://launchpad.net/~ondrej/+archive/php5

  • Is it stable now? – Dmitry Jun 21 '13 at 13:10
  • Yes, there are still couple of missing extensions which I will provide in due time, and it also needs newer Apache 2.4 (also included), but I would say that the repository is in good shape. – oerdnj Jun 22 '13 at 6:11
1

I could not find PPA for 5.5 (and rightly so) so I think either you wait or build it yourself. Instruction to build yourself are found here However, if you like, few PPAs for PHP 5.4 exists if that can be compromise.

Checkout these:

https://launchpad.net/~ondrej/+archive/php5

https://launchpad.net/~nathan-renniewaldock/+archive/ppa

*EDIT*

The ppa:ondrej/php5 now contains PHP 5.5. PHP 5.4 has been moved to ppa:ondrej/php5-oldstable. So you have what you want!

  • 2
    JFTR The ppa:ondrej/php5 now contains PHP 5.5. PHP 5.4 has been moved to ppa:ondrej/php5-oldstable. – oerdnj Jul 30 '13 at 14:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.