1

Running Ubuntu 13.04, I have a problem with my wifi. When booting after a proper shut down, there's never any wifi connection. The system states

Wifi is disabled by hardware switch

However, pressing the hardware switch doesn't change anything.

The only workaround I have is to plug in an ethernet cable, wait for connection, then remove it. Now, a wifi connection can be established. The hardware button now functions as expected.

This is of course very annoying. First, the wifi shouldn't been disabled if it wasn't before the last shut down. Second, it should be capable of turning it on by pressing the button which is supposedly turned off. Third, it shouldn't magically flip the button through the wonderful presence of an ethernet cable. And as a bonus: It would be nice to have the state of the wifi button displayed with the little LED next to the wifi button (which it did on Ubuntu 12.04 and every other decent operating system I ran so far).

The hardware I'm working with is a Broadcom BCM4313 802.11b/g/n Wireless LAN Controller.


Now of course I tried to enable the proprietary driver for this wifi controller, but it still has issues:

After a proper boot, wifi is not connecting, not ever. Disabling the currently active (with LED correctly indicating the status, woohoo!) wifi via hardware button and turning it on again, does not change anything. The only workaround is -- again -- plugging in an ethernet cable and removing it.


Well I don't always have an ethernet cable with me, I'm not always at home and afaik I also need something on the other side of the cable otherwise it's not even detected, so this just isn't a solution.

Is there a proper fix for this? Otherwise, is there a software way to trick Ubuntu into thinking that a wired connection has been made?

7
0

Apparently this is part of a bigger problem with certain Broadcom chips, see https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1097519

Instead use the driver brcmsmac, that actually works with BCM4313

Also, there's loads of info here, but I haven't looked through it all, may be you find something relevant

1
  • Sadly, this did not help.
    – stefan
    Jun 17 '13 at 14:16
0

try rfkill unblock all

rfkill enables and disables wireless devices

0

try

 rfkill unblock wlan0

it will switch wlan0 or other wireless

0

This is not an Ubuntu issue. This is not any driver issue. This is caused by me (and possibly you).

While watching some video... I tried to increase volume with: Fn + F10 key combination ... But I mistakenly pressed Fn + F12 which was Wifi button with 'Radio' symbol on it, which disabled my wifi connection.

Running below command in Terminal, you can see the issue:

> rfkill list all
    
    0: Toshiba Bluetooth: Bluetooth           #or whatever it is
        Soft blocked: no
        Hard blocked: no
    1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes    `<------ that's because I press Wifi button (above) `mistakenly`

Solution: Press again the Fn + F12 (or, some other key where you have Radio symbol)

Now run again the same command:

> rfkill list all

    0: Toshiba Bluetooth: Bluetooth           #or whatever it is
        Soft blocked: no
        Hard blocked: no
    1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

    <------ no means solved.

Now, go to:

(Windows button, if you have on the keyboard) > Settings > Wifi > move to On > select your Wiki connection to enter credentials

Done, your internet is back on.

Reference = here

I hope this works ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.