4

This question already has an answer here:

I ran the following command in chroot environment without X:

gsettings set org.gnome.desktop.a11y.applications screen-reader-enabled true

I get the following error message:

(process:8290): WARNING **: Command line `dbus-launch --autolaunch=09be9504960407430fb3a253000052a5 --binary-syntax --close-stderr' exited with non-zero exit status 1: No protocol specified\nNo protocol specified\nAutolaunch error: X11 initialization failed.

Is X a must for changing gsettings? Is there another way to change the setting? (My purpose is to make a LiveCD iso with screen reader enabled by default)

Thanks!

marked as duplicate by Jorge Castro, Eric Carvalho, Radu Rădeanu, Kevin Bowen, Seth Jul 31 '13 at 23:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3

It's possible to run gsettings without X11 using dbus-launch --exit-with-session:

dbus-launch --exit-with-session gsettings set org.gnome.desktop.a11y.applications screen-reader-enabled true

Not the answer you're looking for? Browse other questions tagged or ask your own question.