I installed unity, used for a while. Then i installed gnome-shell, used it for a while. Now decided to switch back to standard. Gnome is not working the way it use to be. I am using T61 with nvidia-latest drivers. Following issues...

  1. Window borders are not showing. Installed compiz settings, and re-check window decorations option.
  2. I had to re-install nvidia driver, as when I tried to apply normal visual effects, it said no display driver found.
  3. Gnome panel is not coming, and mouse pointer is a "cross" than a "arrow". I then opened a terminal and enter gnome-panel. Panel came and window borders came back.
  4. Nothing is showing on desktop, and the right click is also not populating the menu.
  5. When i loging, an error message saying, docky did not start and it requires compiz to work. After starting gnome-panel from terminal, i went to system>preferences>Appearance. And selected normal visual effects. It activated, i selected keep the settings.

Now when i restart or re-login, everything is gone. I have to run gnome-panel manually, and then re-enable visual setting. Ofcourse i can add gnome-panel in startup applications, but i want to know what has installing unity/gnome-shell has done, that these setting are messed up.

I manually removed mutter, as Appearance application was showing mutter installed, cant enable effects. What shall i do to get back a standard gnome-desktop back.


Are you selecting the "classic" session from the login screen? The empty-desktop-of-doom was a bug that plagued Unity a few weeks back - so you might also want to make 110% sure you have all the latest updates installed.

  • yes i had the latest updates installed. Yes i am selecting the gnome in gdm :(. – Vivek Sharma Mar 18 '11 at 14:31

Could you be more specific? What version of gnome-shell did you use? Did you compile it from git or use the version in the Maverick repos? What version of Ubuntu are you running? The alpha version of 11.04? What version of Unity did you install?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.