117

I was trying to install Ubuntu 12.04 in VirtualBox 4.2.12r84980. I see

this kernel requires an x86-64 CPU, but only detects an i686 CPU, unable to boot

But I am using a 64 bit Windows 8, and trying same .iso for trying Ubuntu. Then what is the problem?

145

To be able to run a 64-bit OS in Virtual Box we have to make sure the virtual machine's architecture is set to 64-bit too.

  • Choose Ubuntu 64-bit in General -> Basic settings on creation of your VM

    enter image description here

  • In addition, for running 64-bit guests it is recommended to enable the Input/Output APIC in the System -> Motherboard settings for your virtual machine:

  • In the System -> Acceleration tab we may want to enable the hardware virtualization features VT-x/AMD-V of your CPU.

  • On the host system we may have to enable hardware virtualization in the BIOS.

  • In some systems a host BIOS option to prevent non-trusted execution needs to be turned off (source).

  • 1
    For me even 'Ubuntu (64-bit)' is not listing in dropdown. All OS listing in dropdown are showing '(32-bit)'. – ARUN Jul 15 '17 at 3:19
  • @ARUN had you enabled virtualization in BIOS? – Takkat Jul 15 '17 at 6:51
  • @ARUN I had the same issue. While creating it, it wasn't an option but after it's created, you can go back into settings > general and it'll be in that list. – Sinaesthetic Aug 20 '17 at 0:21
21

Open the virtual machine settings. Go to the Version dropdown box (General > Basic > Version).

If you don't see "Ubuntu(64 bit)" as an option in the dropdown, it means that virtualization is not enabled on the host.

Reboot the host, go in to BIOS and enable Virtualization. Exit the BIOS, making sure you save changes.

Now, you should see all the 64 bit options in the Version dropdown box.

Virtual machine general settings

5

For those of you who are like me and don't have an option on your virtual box to select the version: Ubuntu(64 bit):

Do this: download the 32 bit Ubuntu iso. ESPECIALLY if when downloading Ubuntu on your virtual box, you chose to allocate less than 2GB of memory.

0
vboxmanage createvm --name "ubuntu" --ostype Ubuntu_64 --register

or if you have already created then,

vboxmanage modifyvm --ostype Ubuntu_64

To list all the ostype: http://zeblog.co/?p=390

protected by Community Jan 26 '14 at 18:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.