5

Xubuntu 12.04. HP Compaq nc8430. 2 GB RAM. Wine 1.4.

I'm trying to run Castle of the Winds, an old 16-bit Windows application, in Wine. I've put the application in .wine/drive_c. I've added it as an application in Wine, and I've tried setting the Windows version to 3.1, and I've also tried Win XP. Each time I try to run the app, Xubuntu freezes. I can do a Ctl-Alt-F4, and then a Ctl-Alt-Del to reboot. This application is not a DOS application, so I don't think DOSbox will help.

Any ideas?

10

Updated answer for 2020-2021

Here are the steps to run this 16-bit App:

  1. sudo dpkg --add-architecture i386
  2. wget -nc https://dl.winehq.org/wine-builds/winehq.key
  3. sudo apt-key add winehq.key
  4. sudo add-apt-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ focal main' I am using 20.04, but change focal to groovy if you are using 20.10.
  5. sudo apt install --install-recommends winehq-devel Change winehq-devel to winehq-stable if you would like to use the stable version instead
  6. Run winecfg once so it installs all required packages to work correctly like gecko. In some cases as mentioned below, it would be needed to set the Windows version to XP.
  7. Visit the Castle in the Wind folder. For me it showed both versions inside of it:

enter image description here

  1. Go to Castle1 for example and on the terminal type wine CASTLE1.EXE to begin

enter image description here

For Castle2, type wine CASTLE2.EXE in the terminal, inside this folder to play it

enter image description here

NOTES

  • I am playing in Ubuntu 20.04
  • I did not install any additional packages via winetricks.
  • There are less steps to do now with the latest wine version, which at this time is Wine 6.0-rc3
  • There was no need to changing the Window version inside winecfg since it worked with Windows XP, 7, 8 and 10 (In my case). The default one was windows 7, which is the one used for this test. But as noted by Adrian, he needed Windows XP (Like the previous version of this answer) to make it work.
24
  • Ok, the error stream (I figured the stdout was uninteresting) from the sudo apt-get update command is here: pastebin.com/u8jxKTUq. Jun 19 '13 at 19:36
  • 1
    For the BADSIG see askubuntu.com/questions/1877/… Jun 19 '13 at 20:49
  • 1
    For the wine files with locate I would first do a apt-get purge then continue with something similar to this askubuntu.com/questions/86702/… to delete all wine files. The files located inside your home folder are never deleted byt apt-get purge for safety reasons. I would delete the "/usr/lib/i386-linux-gnu/wine/" folder before doing this. Save you some time there. Before doing this however, you need to first remove the wine PPA since it also appears on that locate list. Jun 19 '13 at 20:53
  • 1
    I should also mention your problems are already outside the scope of running a 16 bit game on wine. You have other issues so I recommend searching in Askubuntu for each case. The BADSIG was one. The additional packages in /var/lig/dpkg and /var/cache/apt showed that you tried several versions, this means you need to do a cleanup using apt-get / aptitude first before installing wine again. So please search askubuntu for any other issues that are not related to 16 bit on wine since all of this issues have already been mentioned. Jun 19 '13 at 20:58
  • 1
    Well, kudos to @LuisAlvarado: the latest version of Wine with as many of the packages listed above installed, works. It even works better than before, on account of the spell animations working (they didn't before). So, excellent! Sep 29 '18 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.