I keep receiving this error every-time I try to do some updates.

I tried sudo dpkg --configure, sudo apt-get update and sudo apt-get install -f but they failed on me.

installArchives() failed: (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%  

 dpkg: unrecoverable fatal error, aborting:

 failed to read on buffer copy for files list for package `libc6-i386': Is a directory

I tried to find the file but it appears to be missing.

ls: cannot access /var/lib/dpkg/info/libc6-i386: No such file or directory


bash: /var/lib/dpkg/info/libc6-i386: No such file or directory

  • Can you post the output of ls -l /var/lib/dpkg/info/libc6-i386*? – arrange Mar 18 '11 at 8:28
  • how do i post it? – Jonthue Michel Mar 18 '11 at 18:40
  • i mean how do i get it? – Jonthue Michel Mar 18 '11 at 18:45
  • @JorgeCastro How do i obtain the output of that? Sorry still learning! – Jonthue Michel Mar 18 '11 at 19:02
  • @Jonthue Run the command that arrange says in a terminal, then edit your question and add the result of that command there. That will give us information we'll need, thanks! – Jorge Castro Mar 18 '11 at 22:16

You might want to take a look at the following:

Unfortunately for you, both of them point to a corrupted disk ...

  • dose that mean i may have to buy anew hd? – Jonthue Michel Mar 18 '11 at 19:13
  • 1
    It's impossible to tell, given the information you've provided. I would try fsck first as the links above suggested. – J. Taylor Mar 19 '11 at 21:26
  • @JonthueMichel: quite likely you just need to run a disk check. – RolandiXor Apr 15 '11 at 3:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.