1

How do we install cinnamon in Ubuntu raring? I added deb http://packages.linuxmint.com/ debian main import backport upstream romeo to the sources list and used apt-get update to update the sources.

The result was :

Fetched 523 kB in 1h 0min 24s (144 B/s)
Reading package lists... Done
W: GPG error: http://packages.linuxmint.com debian Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3EE67F3D0FF405B2

Next, I tried installing cinnamon as follows, I get errors...

$ sudo apt-get install cinnamon nemo 
[sudo] password for roshan: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cinnamon : Depends: gir1.2-muffin-3.0 but it is not going to be installed
            Depends: libcogl-pango0 (>= 1.7.4) but it is not installable
            Depends: libcogl9 (>= 1.9.6) but it is not installable
            Depends: libgjs0b (>= 1.32.0) but it is not installable
            Depends: libgnome-desktop-3-2 (>= 3.2.0) but it is not installable
            Depends: libmuffin0 but it is not going to be installed
            Recommends: gnome-themes-standard but it is not going to be installed
            Recommends: cinnamon-screensaver but it is not going to be installed
            Recommends: gir1.2-gjsdbus-1.0 but it is not installable
 nemo : Depends: libgnome-desktop-3-2 (>= 3.2.0) but it is not installable
        Recommends: nemo-fileroller but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

How to correct this?

1
  • Hi Roshan, fossfreedom covers this question with an excellent answer in the duplicate link provided. It will help you solve this problem although I recommend removing that PPA you added from linuxmint first. – Luis Alvarado Jun 15 '13 at 5:26

Browse other questions tagged or ask your own question.