I'm trying to connect my Galaxy Nexus to an Ubuntu 11.04 PC by following the instructions in this other post (Getting MTP enabled devices to work with Ubuntu?).

I've read it and redone each step about 10 times, but the best I can get from it when trying to access (on terminal) the directory /media/myGalaxyNexus is the following error:

ls: cannot access /media/myGalaxyNexus: Transport endpoint is not connected
total 0
d????????? ? ? ? ?                ? myGalaxyNexus

This is the result of the command cat ~/.bashrc (only the part related to this post...):

alias android-connect="mtpfs -o allow_other /media/myGalaxyNexus"
alias android-disconnect="fusermount -u /media/myGalaxyNexus"

This is the result of the command cat /etc/udev/rules.d/51-android.rules:

SUBSYSTEM=="usb", ATTR{idVendor}=="04e8", ATTR{idProduct}=="685c", MODE="0666"

This is the result of the command mtp-detect:

libmtp version: 1.1.1
Listing raw device(s)
Device 0 (VID=04e8 and PID=685c) is UNKNOWN.
Please report this VID/PID and the device model to the libmtp development team
  Found 1 device(s):
   04e8:685c @ bus 2, dev 3

I've also found this useful link but neither that helped me. The best I was able to get by following it was to show a directory named Playlist that was empty.

  • You're doing it wrong. If you use 12.04 or later, then you should use the following solution. Note that it is recommended to reboot your computer after you have added a udev rule and that the android lockscreen denies access to the phones data when the device is in standby/locked. If it still does not work, replug it once. askubuntu.com/questions/247943/… – LiveWireBT Jun 14 '13 at 21:15
  • Supplemental: The udev rules are just for configuring developer access (namely adb and fastboot). source.android.com/source/initializing.html So by default MTP should work out of the box ind 13.04 or with the PPA in 12.04. – LiveWireBT Jun 14 '13 at 21:28
  • @LiveWireBT - what am I doing wrong? I've done all of the steps in the answer from here, also reboot after adding a new udev rule. Is it just that 11.04 is too old OS? I can't believe that... – Matteo Jun 14 '13 at 22:56
  • Sorry what I really wanted to say was, that there is a better solution for solving this issue. I should have put a smiley in there. And yes, 11.04 has reached it's end of life, as well as 11.10. wiki.ubuntu.com/Releases [Jorge Castro's][1] post pretty much covers it: Get 12.04 and install the PPA (and forget everything else). [1]: askubuntu.com/questions/247943/… I also added an answer to the question you referenced. The solution is available for months but people still follow old tutorials. :( – LiveWireBT Jun 14 '13 at 23:23
  • LivrWireBT, Could you add your solution to this question? – Anders Jun 16 '13 at 15:58

There is a better solution than the mtpfs solution available for 12.04 and later releases. I'm reposting the solution here on request so that this question can be marked as solved. The original can be found here: Getting MTP enabled devices to work with Ubuntu?

Connecting Android devices via MTP with GVFS

(Out of the box as of 13.04)

Since 13.04 storage access to Android devices via MTP works out of the box. This was possible due to updates for GVFS by Philip Langdale. For 12.04 and 12.10 there exists a PPA with backported versions of the necessary packages.

Note that your device must be unlocked to access the storage of the device with Ubuntu via MTP.

showing device in nautilus in locked and unlocked state

If you get an error message, try to replug the device once.

error message that might pop up when connecting

Citation from Jorge Castro's on adding the PPA for Are there any plans to improve mtp support on future Ubuntu releases?:

  1. Add the PPA to your system

    sudo add-apt-repository ppa:langdalepl/gvfs-mtp
    sudo apt-get update
  2. Then, launch Software Updater (previously known as Update Manager) and install the available updates.

  3. Once everything has been updated successfully, restart your computer, unlock your Android device, connect it via USB and it should show up in your file manager.

Please refer to What are PPAs and how do I use them? if you have questions about anything related to a Personal Package Archives (PPA) and refer to the source on Web Upd8 (it has some comments worth reading).

To clear things up:

  1. You don't need to unlock the booloader (fastboot oem unlock) or root your phone. Unlocking just refers to the Android lockscreen in this answer.
  2. You don't need to add udev rules to get MTP access. These are meant for developer access (adb and fastboot protocols). You can find the original instructions over at the android site if you're interested (chapter: Configuring USB Access).
  3. This solution applies to all Android devices providing MTP functionality and probably all non-Android devices with MTP functionality.
  • THks for posting! Let me try an I'll give you feedback asap! – Matteo Jun 18 '13 at 23:36

Curiously enough, the application called Gigolo does a really good job at detecting and mounting Android devices. I was using my Galaxy Nexus. It just magically showed up in Gigolo's list of available devices. I right-clicked and "connected" the Galaxy Nexus, then I right-clicked it again and "open" worked to launch it in my file browser.

I was using Xubuntu 13.10 doing this. This should be the command for installing it from the terminal:

$ apt-get install gigolo

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.