2

I'm running Xubuntu 13.04 and I can't seem to get the right Lithuanian keyboard layout. None of layouts listed below works correct

enter image description here

Correct Lithuanian layout that I need:

enter image description here

Lithuanian symbols positioned in the place of digits: 1 for Ą, 2 for Č, 3 for Ę, 4 for Ė, 5 for Į, 6 for Š, 7 for Ų, 8 for Ū and = for Ž.

Any help is greatly appreciated.

3

To get the correct Lithuanian language support. Just need to select the Lithuanian language. Such as:

enter image description here

then everything works fine. Tested on Xubuntu 15.04. And selecting the Lithuanian (US keyboard with Lithuanian characters). Get better with the team setxkbmap -variant, but before the first reboot. That would be as follows:

enter image description here

then press Ok and everything works as it should work.

1
  • yep, selection of whole category "Lithuanian" instead of specific ones gives normal LT layout
    – Max
    Nov 4 '17 at 15:42
1

This is how I managed to get proper Lithuanian keyboard layout.

  1. Choose "Lithuanian (standard)" from Keyboard layout selection window.
  2. Set layout change option to "Alt+Shift" or anything else you like.
  3. Change variant of the keyboard layout by executing command in terminal: setxkbmap -variant ,
1
  • If you want to load the script automatically in XFCE, then create a new entry via "Settings Manager" → "Session and Startup" → "Application Autostart" with the following command: /bin/bash -c "sleep 5; setxkbmap -variant ,"
    – Weecka
    Jun 27 '14 at 19:36
0

i took screenshots of these layouts from default ubuntu. take one then search for extended/special characters and compose key... default: default ibm: ibmlst standard: standard us: us

2
  • Thanks for your help pvtmert, if I understood correctly I need to adjust /etc/default/keyboard XKBOPTIONS="" with AltGr.. it seems to be easier install ubuntu default :) Jun 14 '13 at 19:10
  • Well, not necessarily. The AltGr key will only do want you want if you have the right layout. Ubuntu Unity has 6 keyboards listed: the 5 in your image plus 1 more - the one that you want. The question is why isn't the 6th keyboard listed.
    – chaskes
    Jun 14 '13 at 19:16
0

This may be only a partial answer.

Unity has the keyboard that you want. Keyboard Layout has all of the ones listed in your screenshot, but it also has one just called Lithuanian, which has the layout you are looking for.

It's located at /usr/share/X11/xkb/symbols/sun_vndr/lt It's installed as part of the package xkb-data and is part of the Xubuntu desktop.

The layout by itself is also available online: xkeyboard-config-emacs

You may be able to reinstall the package sudo apt-get install --reinstall xkb-data.

I think you can also copy the layout the same location if it's missing from your system; but I'm not entirely sure how XFCE/Xubuntu may have changed this configuration and whether or not you need to use any X11 command line tools.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.