I have 3 relevant partitions split between 2 disks,

  • sda2: Windows 1 partition
  • sda3: Ubuntu partition
  • sdb1: Data partition

I was using pysdm to add a label to my partitions and somehow I seem to have screwed up my installation. Now, every time I access the Data partition mounted in /media/Data I see the files in my Windows partition, and viceversa. I've tried unmounting and remounting correctly to no avail, it seems that wherever I mount sda2, if I access that folder I get the files in sdb1, and viceversa.

Anyone know what may have happened and how to solve this?


This is the result of blkid:

/dev/sda1: LABEL="System Reserved" UUID="C62603F02603E073" TYPE="ntfs"

/dev/sda2: LABEL="Windows" UUID="00A6D498A6D49010" TYPE="ntfs"

/dev/sda5: UUID="033cac3b-6f77-4f09-a629-495dc866866a" TYPE="ext4"

/dev/sdb1: LABEL="Data" UUID="BCD83AE3D83A9B98" TYPE="ntfs"

These are the contents of my ftsab file:

UUID=033cac3b-6f77-4f09-a629-495dc866866a / ext4 errors=remount-ro,user_xattr 0 1

/dev/sda1 /media/Boot_old ntfs defaults 0 0

/dev/sda2 /media/Windows ntfs defaults 0 0

/dev/sdb1 /media/Data ntfs nls=iso8859-1,ro,users,umask=000 0 0

  • Are you using /etc/fstab with UUID mounting? – antivirtel Mar 17 '11 at 22:21
  • let me see if i understand, you have 2 HDD...right?...into this you have 3 partitions??..could you explain me why you dont have 1 HHD with ubuntu and windows partition, and 2nd HDD just to storage data? run: blkid and post the result. – Turk182 Mar 17 '11 at 22:24
  • please include out put of sudo fdisk -l and sudo cat /etc/fstab – nelaaro Apr 8 '11 at 11:54
  • Another info you could provide: screenshots from System>Administratons>Disk Utility – luri Apr 8 '11 at 16:54
  • could you post the out put of the following command ls -la /dev/disk/by-*. Would like to see how the directories and devices are actually mapped. – nelaaro Apr 11 '11 at 6:58

Use the UUID instead of the device name. /dev/sda and /dev/sdb can change places.

UUID=BCD83AE3D83A9B98 /media/Data ntfs nls=iso8859-1,ro,users,umask=000 0 0

  • I tried modifying fstab to boot using the UUIDs but I get the same result. I took the UUIDs from sudo blkid. I could swap the UUIDs and that would make the boot points and labels match, but it doesn't fix the fact that the discs appear to be in the wrong devices. Even gparted shows them wrong, if I take the partition in disk 1 that contains Windows, look up the UUID, mount the device to a folder using the UUID and then look at the contents, I end up seeing the contents of the Data partition :S – Diego Apr 7 '11 at 1:20
  • 1
    @Diego there is no such thing as "the wrong device". It shows up where it shows up, which is why you use the UUID instead of device name to refer to it. If you use the line above, then it will mount your data partition in /media/Data, whether it is on sda or sdb or sdz. – psusi Apr 7 '11 at 13:10
  • I know what you mean, but things are clearly wrong. According to Ubuntu, my Data and Ubuntu partitions are on the same disk, and the Windows partition is in the other. This is plainly impossible, as the Data partition is 500GB, Ubuntu is 50GB and the disk's capacity is 500GB. – Diego Apr 7 '11 at 23:16
  • 1
    @Diego it doesn't say that at all; it says windows and ubuntu are on one disk, and the other is your "Data" partition. – psusi Apr 8 '11 at 1:00
  • 1
    sda and sdb just mean storage device a and storage device b, with the number coming after being the number of the partition on that device. Which hard disk is assigned to a and which to b can change sometimes (its happened to me before). Using UUID's as psusi suggests is the best way to stop ubuntu getting confused and re-ordering them. As you say Diego "Things are clearly wrong", well yes, just use the UUIDs instead and thing should hopefully then be "clearly right". – Slipstream Apr 11 '11 at 9:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.