1

I use Ubuntu 12.04.2 and I've just finished running apt-get update. According to apt-get upgrade, there are 5 packages to be upgraded, in a total of 1533 kB; while the update manager indicates there are 52,8 MB in 13 pacakges.

Why the discrepancy? (also, why apt-get upgrade says 4 packages won't be upgraded?)

output of apt-get upgrade

ruda@machine:~$ sudo apt-get upgrade 
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os pacotes a seguir serão mantidos em suas versões atuais:
  libminiupnpc8 linux-generic linux-headers-generic linux-image-generic
Os pacotes a seguir serão atualizados:
  dbus dbus-x11 libdbus-1-3 libdbus-1-3:i386 linux-libc-dev
5 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 4 não atualizados.
É preciso baixar 1.533 kB de arquivos.
Depois desta operação, 7.168 B adicionais de espaço em disco serão usados.

 

packages marked by update manager

enter image description here enter image description here enter image description here enter image description here

output of sudo apt-get dist-upgrade --simulate

Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Calculando atualização... Pronto
Os NOVOS pacotes a seguir serão instalados:
  linux-headers-3.2.0-48 linux-headers-3.2.0-48-generic linux-image-3.2.0-48-generic minissdpd
Os pacotes a seguir serão atualizados:
  dbus dbus-x11 libdbus-1-3 libdbus-1-3:i386 libminiupnpc8 linux-generic linux-headers-generic linux-image-generic linux-libc-dev
9 pacotes atualizados, 4 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
Inst libdbus-1-3 [1.4.18-1ubuntu1.3] (1.4.18-1ubuntu1.4 Ubuntu:12.04/precise-updates [amd64]) [libdbus-1-3:amd64 on libdbus-1-3:i386] [libdbus-1-3:i386 on libdbus-1-3:amd64] [libdbus-1-3:i386 ]
Inst libdbus-1-3:i386 [1.4.18-1ubuntu1.3] (1.4.18-1ubuntu1.4 Ubuntu:12.04/precise-updates [i386])
Conf libdbus-1-3 (1.4.18-1ubuntu1.4 Ubuntu:12.04/precise-updates [amd64])
Conf libdbus-1-3:i386 (1.4.18-1ubuntu1.4 Ubuntu:12.04/precise-updates [i386])
Inst linux-image-3.2.0-48-generic (3.2.0-48.74 Ubuntu:12.04/precise-updates [amd64])
Inst dbus [1.4.18-1ubuntu1.3] (1.4.18-1ubuntu1.4 Ubuntu:12.04/precise-updates [amd64])
Inst dbus-x11 [1.4.18-1ubuntu1.3] (1.4.18-1ubuntu1.4 Ubuntu:12.04/precise-updates [amd64])
Inst libminiupnpc8 [1.6-3ubuntu1] (1.6-precise2 Bitcoin - Stable Channel:12.04/precise [amd64])
Inst linux-generic [3.2.0.45.54] (3.2.0.48.58 Ubuntu:12.04/precise-updates [amd64]) []
Inst linux-image-generic [3.2.0.45.54] (3.2.0.48.58 Ubuntu:12.04/precise-updates [amd64]) []
Inst linux-headers-3.2.0-48 (3.2.0-48.74 Ubuntu:12.04/precise-updates [all]) []
Inst linux-headers-3.2.0-48-generic (3.2.0-48.74 Ubuntu:12.04/precise-updates [amd64]) []
Inst linux-headers-generic [3.2.0.45.54] (3.2.0.48.58 Ubuntu:12.04/precise-updates [amd64])
Inst linux-libc-dev [3.2.0-45.70] (3.2.0-48.74 Ubuntu:12.04/precise-updates [amd64])
Inst minissdpd (1.1.20111007-3 Ubuntu:12.04/precise [amd64])
Conf linux-image-3.2.0-48-generic (3.2.0-48.74 Ubuntu:12.04/precise-updates [amd64])
Conf dbus (1.4.18-1ubuntu1.4 Ubuntu:12.04/precise-updates [amd64])
Conf dbus-x11 (1.4.18-1ubuntu1.4 Ubuntu:12.04/precise-updates [amd64])
Conf libminiupnpc8 (1.6-precise2 Bitcoin - Stable Channel:12.04/precise [amd64])
Conf linux-image-generic (3.2.0.48.58 Ubuntu:12.04/precise-updates [amd64])
Conf linux-headers-3.2.0-48 (3.2.0-48.74 Ubuntu:12.04/precise-updates [all])
Conf linux-headers-3.2.0-48-generic (3.2.0-48.74 Ubuntu:12.04/precise-updates [amd64])
Conf linux-headers-generic (3.2.0.48.58 Ubuntu:12.04/precise-updates [amd64])
Conf linux-generic (3.2.0.48.58 Ubuntu:12.04/precise-updates [amd64])
Conf linux-libc-dev (3.2.0-48.74 Ubuntu:12.04/precise-updates [amd64])
Conf minissdpd (1.1.20111007-3 Ubuntu:12.04/precise [amd64])
5
  • 1
    apt-get upgrade refuses to install or remove stuff for changes in dependencies. apt-get dist-upgrade has no such qualms.
    – strugee
    Jun 14, 2013 at 14:52
  • @strugee Yes, that would explain the 4 packages that apt-get won't upgrade. But (5+4) = 9, what about the four others? Jun 14, 2013 at 14:55
  • 1
    What is the exact output of sudo apt-get dist-upgrade --simulate?
    – gertvdijk
    Jun 14, 2013 at 15:00
  • @gertvdijk Updated my question with this info Jun 14, 2013 at 15:07
  • I don't see any difference. "9 pacotes atualizados, 4 pacotes novos instalados" means 13 updates, just as with the GUI tool.
    – gertvdijk
    Jun 19, 2013 at 16:37

0

Browse other questions tagged or ask your own question.