1

I use VPN (openvpn) on Ubuntu 13.04. I see the IP-s through VPN correctly. The problem is, although I configure the nameserver in the network manager I still doesn't see the domains.

The exported VPN configuration says:

comp-lzo yes
dev tun
proto udp
nobind
auth-nocache
script-security 2
persist-key
persist-tun
user openvpn
group openvpn

/etc/resolv.conf says it will be rewritten, so I don't edit it

/etc/network/interfaces contains only:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

I tried editing:

/etc/dhcp/dhclient.conf

by adding:

interface "eth0" {
        prepend domain-name-servers MY.DNS.IP.ADDRESS;
}

But it doesn't work.

How can I solve it?

1

The OpenVPN server should push appropriate options with dhcp. Just like your router does when you connect over wifi. From my /etc/openvpn/server.conf:

# DNS servers, courtesy of Google
push "dhcp-option DNS 8.8.8.8"
push "dhcp-option DNS 8.8.4.4"
  • Well, the server configuration should be OK -- it works with Windows, it works with some older Ubuntu (11.10, I guess) of one of my co-workers. – Kalmar Jun 13 '13 at 13:22
  • 1
    The issue is that in 12.04, Ubuntu released (as I understand it) Network Manager and Resolveconf on a previously happy world - and it doesn't seem to add the DNS addresses correctly regardless of pushing them across. I'm having the same problem as Kalmar - I have the tunnel working fine, but unless I manually hack resolv.conf and put the DNS server for the network at the other end of the tunnel above the localhost entry I just can't resolve anything on the far end of the tunnel. Ubuntu used to be such a good OS... what happened? – Steve Jul 22 '13 at 4:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.