I use Turpial a lot, but Turpial isn't connecting at all. I can still connect to Twitter thru the OS app (no issues signing in through Online Accounts) and of course I can still sign in using the browser, but Turpial gives me an "Authentication Error" and Choqok fails to do anything.

I've tried changing my password, revoking the Turpial and Ubuntu apps in Twitter and re-enabling them, but then it gives me an "Invalid Credentials" message. I've even removed and installed Turpial multiple times, still nothing.

I can't find any information or resources for this type of error from Turpial online. I think it may be something recent after finding this message elsewhere:

(article related to "Birdie") It looks promising i'm currently using it atm, since all the other twitter clients no longer work due to the API 1.0 shutdown (posted today)

I've never used Choqok before today, so I don't even know if I've set it up properly. It's failing to retrieve or send Tweets it just blank screens, but at least it signs in.

I've figured that this isn't an issue with Ubuntu, or Turpial or Choqok, or the router (already replaced it today), so I don't really know what I'm dealing with here. I hope it's not another API issue, Facebook did something similar just a few weeks ago


Just like previous answers said, Twitter shut down its 1.0 API Wednesday, June 12th 2013. Now Twitter clients have to use the new and controversial 1.1 API. As a consequence, Twitter clients which have not implemented the 1.1 API support yet will be broken until they implement it. Twitter clients for Linux (and Ubuntu) are in different situations :

  • Polly and Birdie both support this 1.1 API. You can use them seamlessly.
  • Choqok and Turpial did not currently support the 1.1 API. So they will not work until their developers implement the 1.1 API support.
  • Hotot's case is a bit different. It officially do not support 1.1 API however it is "1.1 ready". There is a tweak in the settings which enables Hotot to work partially. For exemple, mentions and lists will not work at all, unlike displaying timelines and posting a tweet. To make Hotot work with the 1.1 API, go to Preferences > Advanced and set the "API Base" parameter to "https://api.twitter.com/1.1/". Restart Hotot after that. Its variant for Google Chrome (and Chromium too) "Hotot for Chrome" supports 1.1 API just like Polly and Birdie.
| improve this answer | |
  • The hotot tweak worked, thank you very much. However, It display some errors; it can't find mentions.json and home_timeline.json every time it check for new tweets. – Valkea Jun 14 '13 at 22:25
  • 1
    @Valkea It is normal. API endpoints get 2 parts: "<base URL><endpoint name>". The Hotot tweak only changes the base URL ("https://api.twitter.com/1.1/" for the 1.1 API). As for the endpoint names, Hotot only know the names for the 1.0 API. So if Twitter Developers changed the name of a given endpoint for the 1.1 API, Hotot will not recognize the new name and display an error. It is the case for mentions (statuses/mentions_timeline.json instead of statuses/mentions.json) but not for the Home Timeline (still statuses/home_timeline.json). That's why I wrote that it partially worked. – air-dex Jun 17 '13 at 22:09
  • Is there any possibility to fix this issue? Or just developers can fix it? – Mostafa Shahverdy Oct 9 '13 at 2:57
  • Gwibber seems to be Ok, but the problem is that Gwibber does not respect system proxy, and so I can not use it in my network :-( – Mostafa Shahverdy Oct 9 '13 at 2:59
  • 1
    @MostafaShahverdy Google Chrome version of Hotot works perfectly. For the desktop version, you can ask this on Twiiter (@HototApp developped by @lyricwai). – air-dex Oct 10 '13 at 14:30

I use Turpial, and I'm getting the same "Authentication Error" error. I also tried to use Choqok and Hotot but they doesn't work either. If I check the authorised apps for my account in the browser, Hotot has been added, but it's doesn't work. I have tried to install TwwetCaster on my Android, in order to check if the oauth works, an it does, so I think mobile apps work.

Reading what you say about API 1.0 shutdown, I think these apps haven't switched to the new API. The developers should be updating their applications to support the new API but it may take some time before the updated applications become available to the Software Center.

So don't worry, the problem is not yours. Some Windows apps have been reported to have the same issue.

| improve this answer | |

I use Polly twitter client version 0.93.7 on linux just now and it works. You can download the last release 0.93.9 https://launchpad.net/polly

| improve this answer | |

I found a twitter client that works with the new API. It's called Polly, maybe is too simple, but it works, so I'm using it untill Choqok will be back. (Choqok is going back, https://twitter.com/choqok. Unfortunatelly, I think Turpial not, or al least not for now)


sudo apt-add-repository ppa:conscioususer/polly-daily && sudo apt-get update && sudo apt-get install polly
| improve this answer | |

You can use this patch to get Choqok working while we get the official release. http://tech.chandrahasa.com/2013/06/19/choqok-patch-for-twitter-api-1-1/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.