0

Seemingly at random, my internet stops working on Ubuntu 13.04. Specifically, wired and wireless show as connected, but I cannot reach any page using any web browser or get a ping response.

I can sometimes get a few minutes of internet access when I reboot, although whether or not this happens also appears to be at random. It always disappears, although still shows as being connected, after no more than 5 minutes though.

I've isolated the problem to Ubuntu itself:

  • No issue on Windows 7
  • Issue persists on Unity, Cinnamon desktop, Gnome desktop
  • Issue persists with multiple networks

I've also tried sudo dhclient wlan0 as recommended in a similar thread, with no luck after rebooting.

I'm unsure of what the issue could be, because it worked previously with no issues on 12.10 and 13.04, and I can't isolate any action that caused it.

If anybody has any ideas, I'd be very grateful.

2
  • Check the network routing before and after you see this via netstat -r. Check the status of the ethernet ports via ifconfig before and after. Can you ping a specific IP number and not the name? Then check /etc/resolv.conf before and after.
    – mdpc
    Jun 12, 2013 at 17:05
  • Are you able to reproduce this?
    – Braiam
    Feb 20, 2014 at 3:14

2 Answers 2

2

If you're satisfied with a wired connection, turn off wireless, unplug the network cable and plug it back in when the notification icon reads that you are disconnected.

I don't know why both don't work at the same time in the 3.8 kernels, but this works for me on my Lenovo laptop.

Follow up: 14 June 2013 - I re-enabled WIFI and unplugged my network cable. So far it's working fine.

Having the two on together seems to be the issue in the 3.8 kernels. I still have a 3.5 kernel that doesn't have any problem running both simultaneously.

1
  • Accepted this, seems to have worked. Wired is sufficient for me usually, and hopefully wireless will work fine if I turn wired off. Cheers.
    – Callum M
    Jun 12, 2013 at 17:39
0

I had exactly the same issue on 13.04. My motherboard has 2 network cards and both are connected to the router over the wires.

This is what helped me:

 sudo apt-get remove network-manager*

This will remove the network manager that you can access on a top-right corner from the Unity UI. But it actually made my connection work and it is not dropping pings anymore.

Good luck.

Not the answer you're looking for? Browse other questions tagged or ask your own question.