1

I run Ubuntu 12.04 Precise. A year ago through Advanced Settings or dconf I set my Icon Theme to Faience-Ocre and my Windows Theme to Adwaita Cupertino L Unity. I kept the GTK+ Theme as Adwaita (default).

This morning I was surprised to see Nautilus had reverted back to Icon Theme ubuntu-mono-dark and Radiance Window Theme (both Ubuntu default) while every other application still uses the [dconf] org gnome desktop interface settings i.e. Faience-Ocre Icon Theme and Adwaita Cupertino L Unity Window Theme.

Also when launching Nautilus in Super User mode via

gksu nautilus

Nautilus looks as before, the way I want it.

I went to /usr/share/icons/ and renamed the ubuntu-mono-dark theme as ubuntu-mono-dark.bak . This caused Nautilus to instantly use the gnome icon theme ...

I don't understand what is going on. Why did the Icon theme revert to default ubuntu-mono-dark in Nautilus only for the user? In the mean time I will use another File Manager.

1

Well I found a fix on this. My Ubuntu 12.04 Precise is fairly modified. I installed many packages from Raring 13.04 to install the latest versions of some software. On some occasions I had to build dummy packages to replace official release packages to take care of dependencies. Then I had to block updates of these dummies when I thought these might be upgraded by Ubuntu Updates with my own script.

In addition, Ubuntu Nautilus software is a part of GNOME software. I had to refrain from installing some Raring 13.04 packages because this would break the System Settings --> Updates Available...

After finding some bugs in Nautilus I went to installed a Nautilus 3.4 fork [same version as in Precise] named Nemo which is fully independent of GNOME:

$ sudo add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-stable
$ sudo apt-get update
$ sudo apt-get install nemo

After logging out and back in, Nemo draws the desktop instead of Nautilus. If you want to continue to use Nautilus for drawing the desktop instead of Nemo, do the following:

Run the following command so Nemo shows up in the Startup Applications list (it's hidden by default):

$ sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/nemo-autostart.desktop

At the same time (before the Nemo installation) when right clicking on the background to change desktop background I realized the pop-up as well was affected by the Theme change.

After rebooting the new File Manager Nemo was working well with the Themes I had set in dconf. But to my surprise Nautilus was again working fine with the Themes ...

So maybe it was the Nemo install or maybe I only had to perform a full restart of my Ubuntu 12.04 ... Anyway this rare oddity is solved.

  • Perhaps you could accept your answer here since you solved your own problem? :) – Zanna Oct 20 '16 at 6:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.