I've added many PPAs using the add-apt-repository command. Is there a simple way to remove these PPAs? I've checked in /etc/apt/sources.list for the appropriate deb lines but they aren't there.

This is on a server system so a command line solution would be great!

  • 13
    There is a bug on Launchpad (bugs.launchpad.net/software-properties/+bug/446216) requesting a --remove argument for the add-apt-repository command. I've submitted a merge request (code.launchpad.net/~mac9416/software-properties/…) to get the feature implemented, but it hasn't yet been accepted. Hopefully you'll have this feature soon though. Commented Jul 29, 2010 at 12:42
  • That's great news. It annoyed me a bit that there was no command do undo the adding; a bit like aptitude that only installs! ppa-purge is good but that's not even in the official repos. Commented Jul 30, 2010 at 16:55
  • 1
    Related. (In particular, see this answer of mine for getting ppa-purge to work with multarch.) Commented Sep 1, 2012 at 14:35
  • 2
    i can advise try to search unnecessary then del(rm -rf) one by one them: grep -i WhatYouWantTosearch /etc/apt/sources.list{,.d/*} Commented Mar 23, 2017 at 8:14
  • 3
    With a GUI: sudo synaptic > Configuration > Repositories > PPAs > (select a PPA) > Delete (ot maybe "Remove", not sure of the right translation, I can only check the program options in another language).
    – Fran
    Commented Sep 12, 2018 at 7:32

27 Answers 27


There are a number of options:

  1. Use the --remove flag, similar to how the PPA was added:

    sudo add-apt-repository --remove ppa:whatever/ppa
  2. You can also remove PPAs by deleting the .list files from /etc/apt/sources.list.d directory.

  3. As a safer alternative, you can install ppa-purge:

    sudo apt-get install ppa-purge

    And then remove the PPA, downgrading gracefully packages it provided to packages provided by official repositories:

    sudo ppa-purge ppa:whatever/ppa

    Note that this will uninstall packages provided by the PPA, but not those provided by the official repositories. If you want to remove them, you should tell it to apt:

    sudo apt-get purge package_name
  4. Last but not least, you can also disable or remove PPAs from the "Software Sources" section in Ubuntu Settings with a few clicks of your mouse (no terminal needed).

  • 33
    This will remove the PPA from the repository list but if the package is a newer version of one in the standard repos, you have to manually downgrade the package afterwards. ppa-purge (see other answer) does that for you. Commented Aug 11, 2010 at 14:00
  • 31
    I get add-apt-repository: error: no such option: --remove :-/
    – Rafa
    Commented Feb 18, 2013 at 14:12
  • 8
    it should be sudo apt-add-repository --remove ppa:repo_name/subdirectory
    – MountainX
    Commented Jun 20, 2013 at 23:55
  • 8
    Similarly, I get add-apt-repository: error: no such option: --remove and add-apt-repository: error: no such option: -r
    – virtualxtc
    Commented Apr 30, 2014 at 21:54
  • 4
    The answer above should be amended with the information provided below in case the --remove flag doesn't work. Specifically, remove the entry in the /etc/apt/sources.list.d directory Commented Aug 12, 2014 at 5:35

Simply run apt-add-repository again with the --remove option to remove a PPA added via the command-line. For example:

sudo apt-add-repository --remove ppa:kernel-ppa/ppa

Then update with:

sudo apt-get update
  • will this remove that PPA permanently?
    – Chirag
    Commented Aug 7, 2012 at 23:11
  • 1
    Yes, permanently. To use it again, you must add manually as if you were doing it for the first time.
    – ish
    Commented Aug 7, 2012 at 23:17
  • 6
    For the record, the --remove/-r flag was added in 10.10. Source: askubuntu.com/a/18202/41756
    – Niels Bom
    Commented Mar 27, 2014 at 16:01
  • 6
    As stated above; I'm running 13.10 and I get add-apt-repository: error: no such option: --remove
    – virtualxtc
    Commented Apr 30, 2014 at 21:56
  • 2
    @ClainDsilva It's because you would be stuck on a locally installed version of any packages you may have installed from the PPA. You should always use ppa-purge.
    – John Scott
    Commented Oct 11, 2015 at 22:18

Alternately, as ppas are stored in /etc/apt/sources.list.d you can find the one you want to remove by entering:

ls /etc/apt/sources.list.d

Then when you have noted the name of that offending ppa (e.g. myppa.list), you can enter:

sudo rm -i /etc/apt/sources.list.d/myppa.list

Take care with rm (hence why I have used the interactive switch so you can confirm your actions. Then run sudo apt-get update afterwards.

This method merely removes the ppa .list file; it does not remove any other files or sort out any other problems caused by the ppa; for that you could use ppa-purge after you have got your update ability back (I know you mentioned this in your question, but I am adding this point for future readers): see here for more information on ppa-purge.

Also take into account that if you previously added the key of the repo as trusted you should remove it:

# list the trusted keys
sudo apt-key list
# remove the key
sudo apt-key del KEY_ID
  • I delete full content of /etc/apt/sources.list.d/ folder and still have 4 bad entries :/ why started to fail that now...
    – m3nda
    Commented Jun 12, 2015 at 13:11
  • 2
    Note that when listing keys, they will have lines like pub 2048R/5044912E 2010-02-11. In this case, to delete this key, the KEY_ID is 5044912E. See askubuntu.com/a/107189/108037. I mention this because apt-key del silently failed with OK when passed 2048R/5044912E as the key ID.
    – jamesc
    Commented Jul 9, 2018 at 11:01
  • 3
    On Ubuntu 16 and above, when removing the key, the KEY_ID is the last 8 characters of the second line of the pub. for example you see EB4C 1BFD 4F04 2F6D DDCC EC91 7721 F63B D38B 4796, in this case KEY_ID is D38B4796 so you do: sudo apt-key del D38B4796
    – Emmanuel
    Commented Jan 29, 2020 at 5:41
  • still googling this answer, 6 years later askubuntu.com/questions/307/…
    – philshem
    Commented Feb 3, 2020 at 9:18
  • This worked for me when add-apt-repository --remove didn't do anything. Commented Jun 23, 2020 at 15:27

You can use the

sudo ppa-purge ppa:repository-name/subdirectory

command in a terminal.

You will first need to install ppa-purge to use this command. To do so, use sudo apt-get install ppa-purge or click this button:

Install via the software center
(source: hostmar.co)

Find out more about it here.

  • 6
    This won't work for deleted repositories in which case it fails with "Warning: Could not find package list for PPA: repository-name subdirectory".
    – Lekensteyn
    Commented Oct 27, 2011 at 9:26
  • It's not available for Ubuntu 11.10, or am I wrong?
    – math
    Commented Feb 6, 2012 at 17:14
  • 10
    Yo, this didn't work for me, but I love the syntax so much I am voting it up anyway. Commented Mar 3, 2012 at 2:45
  • @DaveJarvis it's not installed by default on any system =/. I've edited the answer to include information on how to install it.
    – Alaa Ali
    Commented Sep 7, 2013 at 8:33
  • This didn't work for me, apparently it didn't disable the ppa and then did not actually downgrade the packages. However, it prints out a list of packages, like package-name/distribution. If you manually disable the ppa, and then run apt-get install <complete-list-of-those-packages>, apt-get will then automatically downgrade for you, based on the output, I think that's the same that it is doing internally.
    – Berdir
    Commented Jan 9, 2015 at 10:37

The answers to this question will help you.

You can manage PPAs in System > Administration > Software Sources or by removing files in /etc/apt/sources.list.d/.

You can also use a package called ppa-purge.

And, as I commented on the question I linked to above,

There is a bug on Launchpad requesting a --remove argument for the add-apt-repository command. I've submitted a merge request to get the feature implemented, but it hasn't yet been accepted. Hopefully you'll have this feature soon though.

  • 4
    I found it in Ubuntu Software Center > Edit > Software Sources.
    – Josh M.
    Commented Oct 1, 2012 at 15:07
  • The "ppa-purge" link doesn't work. It gives a 404 error. Commented Feb 10, 2014 at 8:05
  • 4
    FYI in Ubuntu 16.04 the way to find the PPA list is System Settings -> System -> Software & Updates -> Other Software
    – knocte
    Commented Jun 10, 2016 at 5:22
  • Would you know how i can get to System > Administration > Software Sources via the command line? (I'm using Ubuntu via i3, so I don't have those menus handy).
    – BenKoshy
    Commented Nov 9, 2020 at 6:40
  • For Ubuntu 20.04 -> Software Updater -> Settings -> Other Software Commented Jul 21, 2022 at 18:24

Some people might prefer to add and remove repositories via a GUI. As of Ubuntu 10.10, this requires a bit of extra work. An explanation is available on the wiki. In order to try and have all answers for this question available in one place, I will try and summarize the important details here. Be sure to check the wiki (especially once a new version of Ubuntu is released) to ensure that this process is still valid.

First, you will want to re-enable 'Software Sources' in the System->Administration menu. Right click on the Applications/Places/System menu and click 'Edit Menus'.

Click 'Edit Menus'

This will open a window, scroll down and click on 'Administration'. Check the box next to 'Software Sources' and then click the 'Close' button.

Check the box next to 'Software Sources'

Go to System->Administration and you should see 'Software Sources' in the menu.

'Software Sources' now in menu

In the window that opens, click on the 'Other Software' tab at the top.

'Other Software' tab

You should see all of the repositories that you have added (including the PPAs added via add-apt-repository). You can temporarily disable a repository by unchecking the box next to it. To remove a repository permanently, highlight it and click on the 'Remove' button. When you are done, hit the 'Close' button.

As Marcel Stimberg noted earlier:

This will remove the PPA from the repository list but if the package is a newer version of one in the standard repos, you have to manually downgrade the package afterwards. ppa-purge (see other answer) does that for you.

Hopefully, this will help.

  • You don't need to edit the menu, there's an entry for Software Sources in the Software Center menu. Commented Dec 29, 2010 at 2:25
  • Thanks. It looks like an issue with gksu on my end caused me to not get presented with the Software Sources when I tried that initially. I'll resolve that issue locally and update the answer.
    – nhandler
    Commented Dec 29, 2010 at 19:16

ppa-purge is your friend. It automatically uninstalls whatever you installed via the ppa and then removes the ppa.

Install ppa-purge via:

sudo apt-get install ppa-purge

and the use it like this:

sudo ppa-purge ppa-url


  • 2
    The OP did already try ppa-purge.
    – jokerdino
    Commented Aug 14, 2012 at 12:00

Since Ubuntu Maverick (10.10) add-apt-repository accepts a -r or --remove parameter which removes the PPA in the same way you installed it. :)


Install: sudo apt-add-repository ppa:user/repository

Uninstall: sudo apt-add-repository -r ppa:user/repository

  • 2
    Thanks! I used sudo apt-add-repository -r ppa:user/repository to uninstall a stubborn ppa from New Linux Counter Project. I have tried a lot of command lines and suggestions but none of them was of any help, only yours worked! Thanks! One info: it works in 12.04 LTS too, not only in Maverick. Commented Feb 10, 2014 at 8:20
  • You're welcome, @CristianaNicolae! I've updated my answer based on your advice, thank you! :) Commented Feb 14, 2014 at 11:33
  • I'm running 13.10 and I get add-apt-repository: error: no such option: -r
    – virtualxtc
    Commented Jul 31, 2014 at 7:33
  • 1
    @virtualxtc I'm currently running Ubuntu 14.04 and it still has options -r and --remove on apt-add-repository command. Thus I think you're using a modified or outdated version of apt-add-repository. This utility is provided by the python-software-properties package, maybe you're using a locked version of it. You can check its source code here: bazaar.launchpad.net/~ubuntu-branches/ubuntu/trusty/… Those removing options was introduced on revision 47, on late 2010. So they exist since 10.10 and never get changed, as you can see in the source. Commented Jul 31, 2014 at 13:03
  • There are a couple other users reporting the same issue, so this lock must be a fairly common thing. Stranger still is that the -r --remove flag options are listed in the man / help files, but still produce the stated error. I'll take a look at my python-software-properties next time I'm in Ubuntu.
    – virtualxtc
    Commented Aug 1, 2014 at 7:29

Run Ubuntu Software Center and from the menu choose "Software Sources" - there you can add/edit/remove repositories.


Run these commands:

sudo add-apt-repository --remove ppa:kernel-ppa/ppa 
sudo apt-get update
  • As stated above; I'm running 13.10 and I get add-apt-repository: error: no such option: --remove
    – virtualxtc
    Commented Apr 30, 2014 at 22:01

Depending if add-apt-repository was invoked with a full sources.list line or a ppa it appends the line to /etc/apt/sources.list or a new file in the /etc/apt/sources.list.d/ directory. If it's a ppa it will then import the ppa GPG key into apt's keyring

To reverse the actions done by add-apt-repository you can either manually remove the apt line or use a tool like "Software Sources" to do it and then remove the GPG key using apt-key like so:

"sudo apt-key list" to find out the id for the repository you want to remove and then
"sudo apt-key del id" where is looks like 7FAC5991. The id is the part after the "/" character.


Using add-apt-repository

Note: This solution does not remove/downgrade packages associated with the repository.

The add-apt-repository command has an option to remove a repository, which is specified with -r. You just need to know the PPA you want to send on its way. Use the command below:

sudo add-apt-repository -r ppa:REPOSITORY/HERE

... changing "PPA/HERE" to the PPA you are removing.


Using ppa-purge

Note: This solution will purge PPA, & downgrade all packages from it.

To install use:

sudo apt install ppa-purge

To use ppa-purge you'd do:

sudo ppa-purge ppa:REPOSITORY/HERE

... changing "REPOSITORY/HERE" to the repository you are removing.


Using Software&Updates

Note: This solution does not remove/downgrade packages associated with the repository.

Search "Software & Updates" (or software-properties-gtk) & launch it then choose tab -> "Other Software". To remove a repository, uncheck it, then click "Close", & lastly "Refresh".

enter image description here


If you are talking about the actual applications installed via a PPA, they will be listed just as any other application and you would uninstall it the same way. The PPAs (repositories) themselves will be listed under the 'Other Software' tab of the Settings->Repositories menu. They can be removed just like any other source.

Screenshot of Synaptic Repository/PPA screen


You can use y-ppa-manager

Installation :

sudo add-apt-repository ppa:webupd8team/y-ppa-manager
sudo apt-get update
sudo apt-get install y-ppa-manager

Use :

Open Y PPA Manager and select Manage PPAs

enter image description here

Select the PPA you want to remove and click the Remove button

enter image description here


You can manage your repositories in System > Administration > Software Sources

You can also remove them in /etc/apt/sources.list.d/ where you'll find a <repo>-ppa-<distro>.list file You can remove that file or simply comment out the deb line


In Linux Mint there is no --remove or -r switch on add-apt-repository. If you want to remove a repository, you'll have to do it manually. It's not hard:

  1. List all installed repositories.

    ls /etc/apt/sources.list.d

    This lists, for example:

    getdeb.list  natecarlson-maven3-trusty.list  official-package-repositories.list
  2. Find the name of the repository you want to remove.
    In my case I want to remove natecarlson-maven3-trusty.list.

  3. Remove the repository.

    sudo rm -i /etc/apt/sources.list.d/natecarlson-maven3-trusty.list
  4. List all the GPG keys.

    apt-key list

    This lists, for example:

    pub   1024D/437D05B5 2004-09-12
    uid                  Ubuntu Archive Automatic Signing Key <[email protected]>
    sub   2048g/79164387 2004-09-12
    pub   1024D/FBB75451 2004-12-30
    uid                  Ubuntu CD Image Automatic Signing Key <[email protected]>
    pub   4096R/46D7E7CF 2009-05-15
    uid                  GetDeb Archive Automatic Signing Key <[email protected]>
    pub   1024R/3DD9F856 2011-04-15
    uid                  Launchpad PPA for Nate Carlson
  5. Find the key ID for the key you want to remove. The key ID is the part after the /.
    In my case I want to remove the Nate Carlson key, so the ID is 3DD9F856.

  6. Remove the key.

    sudo apt-key del 3DD9F856
  7. Update the package lists.

    sudo apt-get update


  • Mint users can also use the built-in Software Sources tool, which was the most convenient solution in my case. Commented Feb 15, 2017 at 20:08

Apart from the solution mentioned already: If you still have software installed from that repository, it is best to revert them to the original version supplied with ubuntu: the one from the ppa will not get (security and other) updates anymore. There is a tool that will do just that: ppa-purge https://packages.ubuntu.com/search?keywords=ppa-purge

  • 1
    ppa-purge is good stuff, but it's also powerful stuff. Commented Dec 20, 2010 at 23:52

There's a command, add-apt-repository -r.

But deleting the file and re-running sudo apt-get update is also fine.

  • 1
    I don§t know how is this meant to behave, but after the command return and apt-get update, corresponding files were still in /etc/apt/list.sources.d. I've removed them manually and re-run update, I don't know if it was necessary.
    – Ivan
    Commented Dec 20, 2010 at 3:18
  • 1
    I'm running 13.10 and I get add-apt-repository: error: no such option: -r
    – virtualxtc
    Commented Apr 30, 2014 at 22:02
  • 1
    That is interesting; the add-apt-repository manual page for 13.10 claims that this option exists. In fact it appeared in 12.04. Commented May 2, 2014 at 9:27

It depends. If you've installed a new application from a ppa, then you can uninstall it normally. However, if you've enabled a ppa to get a newer version of a program that you've alredy installed (Firefox 4,newer Xorg drivers,etc), then you need to use a program called ppa-purge.

Ppa-purge is available in the repositories for Maverick and newer. A backport is available for Lucid users. Just install it and then run

sudo ppa-purge ppa:repository-name/directory

The above command will disable the ppa from your software sources and then reinstall the official version of the upgraded application from the Ubuntu repository.


OMG!Ubuntu! mentioned that this feature had been added to the 'Tweak' PPA.

Presumably once it's in universe, you'll be able to use it to remove itself :)


You can use Ubuntu-Tweak, which makes it very easy to edit ppa. You can delete the ppa's manually or when Ubuntu-Tweak know it just click a button.


You can try those command below and it works very well for me to remove Linux kernel 3.5 (ppa:xorg-edgers/ppa).

sudo apt-get install ppa-purge
sudo ppa-purge ppa:<XXX>/<YYY>

Most simple way to delete all of your PPA'a is this:

cd /etc/apt/sources.list.d && sudo rm -i *list*

It will first take you to the directory which contains sources.list.d and then rm (remove) basically all files with word list in their name.


add-apt-repository now accepts a --remove argument.


I proposed adding a rm-apt-repository command as well:

  • 1
    and as of ubuntu 13.10 they seem to have removed this feature.
    – virtualxtc
    Commented Apr 30, 2014 at 22:04

All these answers are fine, but to me the easiest way is still to remove them directly using rm -rf.

Imagine that apt update gives you the following error:

W: Failed to fetch http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/dists/trusty/main/binary-amd64/Packages  403  Forbidden

Then you can fix it doing something like :

sudo rm -rf /etc/apt/sources.list.d/andrej*
  • Almost identical to RonJohn's answer but I noticed you don't feel running sudo apt update afterwards is necessary? Commented Apr 13, 2018 at 2:52
  • 1
    It is yes. My example didn’t directly said it, but if your apt update fails showing the error above, then removing the source files will make it work again. So it didn’t feel necessary to specify it in this context ;) I get the confusion though. I will edit, thanks for your comment!
    – glemiere
    Commented Apr 13, 2018 at 2:58
  • @glemiere some are not from launchpad, eg Err:12 https://repo.mongodb.org/apt/ubuntu focal/mongodb-org/3.4 Release, the rm command is still the same?
    – Dan D.
    Commented Oct 27, 2022 at 8:18

Create this function (add it to wherever you store your functions) and then run with the appropriate ppa name:

    sudo -- sh -c 'rm /etc/apt/sources.list.d/"$1".list ; apt-get update'

rmppa snagglepuss

Add error checking (non-existent parameter, for example) if you desire...


You can go into directory /etc/apt/sources.list.d and delete the related entries eg.

(note that 2 entries exist for the same entry)

  • sudo trash yann1ck-ubuntu-onedrive-bullseye.list
  • sudo trash yann1ck-ubuntu-onedrive-bullseye.list.save
  • I recommend reading the .list file first and seeing which signature is used and removing it too, e.g. cat /etc/apt/sources.list.d/yann1ck-ubuntu-onedrive-bullseye.list, which will show a "signed by" instruction that points to a file in /usr/share/keyrings/
    – isapir
    Commented Jun 2 at 18:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .