14

I've installed Xfce desktop and removed Ubuntu's default DE. It turns out that making a screenshot requires running a special application called ScreenShot instead of just pressing PrtSc button.

I wonder, how do I do a screenshot in the same way I did before by pressing PrtSc button?

  • 1
    That maybe because of the mix-n-match. A 100% Xubuntu install would have the Prnt Scrn bound to Xfce4-screenshooter. But it appears that the Ubuntu bindings are still in effect. – user25656 Jun 11 '13 at 4:07
  • 1
    Try Shutter. Its an excellent application. See My answer Here. – Mitch Jun 11 '13 at 5:59
  • @vasa1, I asked how to bind PrtSc with making a screenshot command. – Alan Coromano Jun 11 '13 at 6:27
19

Go to

XFCE Menu --> Settings --> Keyboard >>> Application Shortcuts,

and add the "xfce4-screenshooter -f" command to use the "PrintScreen" key in order to take fullscreen screenshots.

Check archlinux wiki for more details. Or look at http://docs.xfce.org/xfce/xfce4-settings/start.

Here's what it looks like: enter image description here

  • but can't add or remove any command from there. – Alan Coromano Jun 11 '13 at 6:18
  • It should work. On clicking add, a small window named shortcut command will open. In the text box, add /usr/bin/xfce4-screenshooter -f, then press OK and press the shortcut button. – nizar malangadan Jun 11 '13 at 14:41
  • there is no 'add' button -- makescreen.ru/i/65ede79a40e0ba10f5ba2a02ab1dc1.jpg – Alan Coromano Jun 12 '13 at 15:48
  • Looks like it is a newer interface. Maybe the feature to add new shortcuts will come later, not in your current version. – nizar malangadan Jun 15 '13 at 13:12
  • I personally recommend using the option -r instead of -f because it gives you the choice of taking the screenshot of whatever region you want. – Prajwal Dhatwalia Nov 15 '18 at 16:23
2

When using the keyboard>>Application Shortcuts to launch xfce-screenshooter, the program will not launch when a menu is opened on the panel. It appears that when the panel's menu is opened, the keyboard shortcut doesn't fire.

However, if you want to capture the menu at the top, open a terminal session and execute the following one liner:

sleep 10s; xfce4-screenshooter -f

... then click on the menu and wait for the snapshot. The one liner will wait for 10 seconds before grabbing a full screen image. Adjust the sleep delay if you need more or less time to wait.

  • Ahh thanks - that's what the problem was - I was trying to get a screenshot of a panel menu! – Brian Burns Apr 7 at 17:49
1

If you are using a Chromebook, you could also adjust key bindings, since there is no "print screen" key.

You could also just use the terminal commands "xfce4-screenshooter -w" to capture the terminal window, or use the -f flag to capture the whole screen and then edit in the image editor of your choice.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.