5

I just upgraded my 12.10 to 13.04 with "great" difficulty, but a few issues persist.

Firefox refuse even to open when I click the icon. I had to tweak a bit to complete the 13.04 upgrade, so it may have something to do with this happening. Funnily enough, I managed to make Chrome work by typing in gateway digits on the bar, so I can rule out the connection or hardware issues. When I tried to open firefox through terminal by typing "firefox", I received the following message. Could someone interpret it for me?

GLIB CRITICAL **: g_slice_set_config: assertion sys_page_size =0=0 failed Could not create gnome accelerators directory home/tom/gnome2/accels permission denied

What went wrong and what can I do?

5

Looks as if you have a permissions problem.

sudo chown -R tom:tom /home/tom
5
  • wow you seem to have a magic wand! Thanks. It worked. Did it make me go as root? Does this command work for most "permission" problems, or just browsers? – user145829 Jun 10 '13 at 21:41
  • hahah, most permission problems in your home directory. You should check ownership of hidden files as well. – Panther Jun 10 '13 at 21:48
  • Why, suddenly, did I need "permission" to open a browser that I was using everyday? – user145829 Jun 11 '13 at 13:05
  • with that command, did I unlock all the files in "home"? And you can apply the same format to any other files? – user145829 Jun 11 '13 at 13:09
  • yes, but you should not use it outside of your home directory without understanding how permissions work - help.ubuntu.com/community/FilePermissions – Panther Jun 11 '13 at 13:12
2

In case you are sure about permissions and want to play it safe you could use the following:

sudo chown -hR $USER ~/.gnome2/
sudo chown -hR $USER ~/.gnome2_private/

Courtesy : Augusto Recordon

change the permission of the files that are causing the problem. Hope this helps

1
  • This should be the top (and accepted) answer because it changes the owner of the folders that need to have their owner changed in order to fix the problem and not of anything else. – zbr Apr 21 '16 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.